summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaweł Hajdan <phajdan.jr@gentoo.org>2013-05-25 00:13:18 +0000
committerPaweł Hajdan <phajdan.jr@gentoo.org>2013-05-25 00:13:18 +0000
commite0058f5d72c5e9c16d9caba6076b0638fa032e42 (patch)
treed9b4c6aa677de8db2de11fa9a7891e8aee669c6d /www-client/chromium/chromium-9999-r1.ebuild
parentold revsions removed. (diff)
downloadhistorical-e0058f5d72c5e9c16d9caba6076b0638fa032e42.tar.gz
historical-e0058f5d72c5e9c16d9caba6076b0638fa032e42.tar.bz2
historical-e0058f5d72c5e9c16d9caba6076b0638fa032e42.zip
Dev channel bump. Switch from make-based to ninja-based build. Fix bug #469144 by Alphat-PC.
Package-Manager: portage-2.1.11.62/cvs/Linux i686 Manifest-Sign-Key: 0x30427902
Diffstat (limited to 'www-client/chromium/chromium-9999-r1.ebuild')
-rw-r--r--www-client/chromium/chromium-9999-r1.ebuild40
1 files changed, 24 insertions, 16 deletions
diff --git a/www-client/chromium/chromium-9999-r1.ebuild b/www-client/chromium/chromium-9999-r1.ebuild
index 9a4cd1a7ed63..447f6be429eb 100644
--- a/www-client/chromium/chromium-9999-r1.ebuild
+++ b/www-client/chromium/chromium-9999-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-9999-r1.ebuild,v 1.194 2013/05/09 20:59:28 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-9999-r1.ebuild,v 1.195 2013/05/25 00:13:09 phajdan.jr Exp $
EAPI="5"
PYTHON_COMPAT=( python{2_6,2_7} )
@@ -9,7 +9,7 @@ CHROMIUM_LANGS="am ar bg bn ca cs da de el en_GB es es_LA et fa fi fil fr gu he
hi hr hu id it ja kn ko lt lv ml mr ms nb nl pl pt_BR pt_PT ro ru sk sl sr
sv sw ta te th tr uk vi zh_CN zh_TW"
-inherit chromium eutils flag-o-matic multilib \
+inherit chromium eutils flag-o-matic multilib multiprocessing \
pax-utils portability python-any-r1 subversion toolchain-funcs versionator virtualx
DESCRIPTION="Open-source version of Google Chrome web browser"
@@ -24,6 +24,10 @@ IUSE="bindist cups gnome gnome-keyring gps kerberos pulseaudio selinux +system-f
# Native Client binaries are compiled with different set of flags, bug #452066.
QA_FLAGS_IGNORED=".*\.nexe"
+# Native Client binaries may be stripped by the build system, which uses the
+# right tools for it, bug #469144 .
+QA_PRESTRIPPED=".*\.nexe"
+
RDEPEND=">=app-accessibility/speech-dispatcher-0.8:=
app-arch/bzip2:=
app-arch/snappy:=
@@ -33,7 +37,7 @@ RDEPEND=">=app-accessibility/speech-dispatcher-0.8:=
>=net-print/cups-1.3.11:=
)
>=dev-lang/v8-3.17.6:=
- =dev-lang/v8-3.18*
+ =dev-lang/v8-3.19*
>=dev-libs/elfutils-0.149
dev-libs/expat:=
>=dev-libs/icu-49.1.1-r1:=
@@ -81,13 +85,14 @@ DEPEND="${RDEPEND}
dev-lang/yasm
)
dev-lang/perl
+ dev-python/jinja
dev-python/ply
dev-python/simplejson
>=dev-util/gperf-3.0.3
+ dev-util/ninja
sys-apps/hwids
>=sys-devel/bison-2.4.3
sys-devel/flex
- >=sys-devel/make-3.81-r2
virtual/pkgconfig
test? ( dev-python/pyftpdlib )"
RDEPEND+="
@@ -180,14 +185,14 @@ pkg_setup() {
src_prepare() {
if ! use arm; then
- mkdir -p out/Release/obj/gen/sdk/toolchain || die
+ mkdir -p out/Release/gen/sdk/toolchain || die
# Do not preserve SELinux context, bug #460892 .
cp -a --no-preserve=context /usr/$(get_libdir)/nacl-toolchain-newlib \
- out/Release/obj/gen/sdk/toolchain/linux_x86_newlib || die
- touch out/Release/obj/gen/sdk/toolchain/linux_x86_newlib/stamp.untar || die
+ out/Release/gen/sdk/toolchain/linux_x86_newlib || die
+ touch out/Release/gen/sdk/toolchain/linux_x86_newlib/stamp.untar || die
fi
- epatch "${FILESDIR}/${PN}-system-ffmpeg-r5.patch"
+ epatch "${FILESDIR}/${PN}-system-ffmpeg-r6.patch"
epatch_user
@@ -410,6 +415,12 @@ src_configure() {
# Tools for building programs to be executed on the build system, bug #410883.
tc-export_build_env BUILD_AR BUILD_CC BUILD_CXX
+ # Tools for building programs to be executed on the build system, bug #410883.
+ export AR_host=$(tc-getBUILD_AR)
+ export CC_host=$(tc-getBUILD_CC)
+ export CXX_host=$(tc-getBUILD_CXX)
+ export LD_host=${CXX_host}
+
build/linux/unbundle/replace_gyp_files.py ${myconf} || die
egyp_chromium ${myconf} || die
}
@@ -422,17 +433,14 @@ src_compile() {
test_targets+=" ${x}_unittests"
done
- local make_targets="chrome chrome_sandbox chromedriver"
+ local ninja_targets="chrome chrome_sandbox chromedriver"
if use test; then
- make_targets+=" $test_targets"
+ ninja_targets+=" $test_targets"
fi
- # See bug #410883 for more info about the .host mess.
- emake ${make_targets} BUILDTYPE=Release V=1 \
- CC.host="${BUILD_CC}" CFLAGS.host="${BUILD_CFLAGS}" \
- CXX.host="${BUILD_CXX}" CXXFLAGS.host="${BUILD_CXXFLAGS}" \
- LINK.host="${BUILD_CXX}" LDFLAGS.host="${BUILD_LDFLAGS}" \
- AR.host="${BUILD_AR}" || die
+ # Even though ninja autodetects number of CPUs, we respect
+ # user's options, for debugging with -j 1 or any other reason.
+ ninja -C out/Release -v -j $(makeopts_jobs) ${ninja_targets} || die
pax-mark m out/Release/chrome
if use test; then