summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaweł Hajdan <phajdan.jr@gentoo.org>2010-12-20 19:06:38 +0000
committerPaweł Hajdan <phajdan.jr@gentoo.org>2010-12-20 19:06:38 +0000
commit3a349c985234c50e737733df787268684a673644 (patch)
tree6bbf5d6ff4e1a03a76a497d96b2a1f5f709d9b3a /www-client/chromium/chromium-9999.ebuild
parentx86 stable wrt bug #349186 (diff)
downloadhistorical-3a349c985234c50e737733df787268684a673644.tar.gz
historical-3a349c985234c50e737733df787268684a673644.tar.bz2
historical-3a349c985234c50e737733df787268684a673644.zip
Add more checks to prevent user problems like bug #299777 or bug #348235.
Package-Manager: portage-2.1.9.25/cvs/Linux i686
Diffstat (limited to 'www-client/chromium/chromium-9999.ebuild')
-rw-r--r--www-client/chromium/chromium-9999.ebuild17
1 files changed, 16 insertions, 1 deletions
diff --git a/www-client/chromium/chromium-9999.ebuild b/www-client/chromium/chromium-9999.ebuild
index c91a0baa4165..3f4d5ab42880 100644
--- a/www-client/chromium/chromium-9999.ebuild
+++ b/www-client/chromium/chromium-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-9999.ebuild,v 1.115 2010/12/12 17:18:47 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-9999.ebuild,v 1.116 2010/12/20 19:06:38 phajdan.jr Exp $
EAPI="3"
PYTHON_DEPEND="2:2.6"
@@ -132,6 +132,12 @@ pkg_setup() {
python_pkg_setup
# Prevent user problems like bug #299777.
+ if ! egrep -q '^shm.+/dev/shm' /etc/fstab; then
+ ewarn "You don't have /dev/shm entry in /etc/fstab."
+ ewarn "${PN} may fail to start in that configuration."
+ ewarn "Please add the following line to your /etc/fstab:"
+ ewarn "shm /dev/shm tmpfs nodev,nosuid,noexec 0 0"
+ fi
if ! grep -q /dev/shm <<< $(get_mounts); then
ewarn "You don't have tmpfs mounted at /dev/shm."
ewarn "${PN} may fail to start in that configuration."
@@ -143,6 +149,15 @@ pkg_setup() {
ewarn "${PN} may fail to start in that configuration."
ewarn "Please run 'chmod 1777 /dev/shm'."
fi
+
+ # Prevent user problems like bug #348235.
+ eshopts_push -s extglob
+ if is-flagq '-g?(gdb)?([1-9])'; then
+ ewarn "You have enabled debug info (probably have -g or -ggdb in your \$C{,XX}FLAGS)."
+ ewarn "You may experience really long compilation times and/or increased memory usage."
+ ewarn "If compilation fails, please try removing -g{,gdb} before reporting a bug."
+ fi
+ eshopts_pop
}
src_prepare() {