summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2006-09-03 10:20:34 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2006-09-03 10:20:34 +0000
commit46832a99edda9cb9e968585b3d1a02e55e6b7672 (patch)
tree12abc89802673e11ab94a9d02d2f2b37fff88e48 /www-client/mozilla-launcher/mozilla-launcher-1.52-r1.ebuild
parentUpdate to kernel-2 eclass. (diff)
downloadhistorical-46832a99edda9cb9e968585b3d1a02e55e6b7672.tar.gz
historical-46832a99edda9cb9e968585b3d1a02e55e6b7672.tar.bz2
historical-46832a99edda9cb9e968585b3d1a02e55e6b7672.zip
Added version with optional media-libs/alsa-oss support.
Package-Manager: portage-2.1.1_rc1-r2
Diffstat (limited to 'www-client/mozilla-launcher/mozilla-launcher-1.52-r1.ebuild')
-rw-r--r--www-client/mozilla-launcher/mozilla-launcher-1.52-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/www-client/mozilla-launcher/mozilla-launcher-1.52-r1.ebuild b/www-client/mozilla-launcher/mozilla-launcher-1.52-r1.ebuild
new file mode 100644
index 000000000000..2366c6e19a16
--- /dev/null
+++ b/www-client/mozilla-launcher/mozilla-launcher-1.52-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/mozilla-launcher/mozilla-launcher-1.52-r1.ebuild,v 1.1 2006/09/03 10:20:34 nelchael Exp $
+
+inherit eutils
+
+DESCRIPTION="Script that launches mozilla or firefox"
+HOMEPAGE="http://dev.gentoo.org/~agriffis/dist/"
+SRC_URI="mirror://gentoo/${P}.bz2
+ http://dev.gentoo.org/~anarchy/dist/${P}.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ppc ~x86"
+IUSE="aoss"
+
+DEPEND=""
+RDEPEND="|| ( x11-apps/xdpyinfo virtual/x11 )
+ aoss? ( media-libs/alsa-oss )"
+
+S=${WORKDIR}
+
+src_install() {
+ use aoss && epatch "${FILESDIR}/${P}-aoss.patch"
+ exeinto /usr/libexec
+ newexe ${P} mozilla-launcher || die
+}
+
+pkg_postinst() {
+ local f
+
+ find ${ROOT}/usr/bin -maxdepth 1 -type l | \
+ while read f; do
+ [[ $(readlink ${f}) == mozilla-launcher ]] || continue
+ einfo "Updating ${f} symlink to /usr/libexec/mozilla-launcher"
+ ln -sfn /usr/libexec/mozilla-launcher ${f}
+ done
+}