summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2013-02-07 08:06:06 +0000
committerWilliam Hubbs <williamh@gentoo.org>2013-02-07 08:06:06 +0000
commit66b6426d3814c1617acbc34d7b9f6feecd8c0f72 (patch)
tree380c2f1583be48e8ed4d082aa5f1a66f717da454 /www-client
parentVersion bump (diff)
downloadhistorical-66b6426d3814c1617acbc34d7b9f6feecd8c0f72.tar.gz
historical-66b6426d3814c1617acbc34d7b9f6feecd8c0f72.tar.bz2
historical-66b6426d3814c1617acbc34d7b9f6feecd8c0f72.zip
install man page, update git support and fix #432174.
Package-Manager: portage-2.2.0_alpha161/cvs/Linux i686 Manifest-Sign-Key: 0x30C46538
Diffstat (limited to 'www-client')
-rw-r--r--www-client/pybugz/pybugz-9999.ebuild18
1 files changed, 7 insertions, 11 deletions
diff --git a/www-client/pybugz/pybugz-9999.ebuild b/www-client/pybugz/pybugz-9999.ebuild
index fea60eb49e44..ed6385f36aa1 100644
--- a/www-client/pybugz/pybugz-9999.ebuild
+++ b/www-client/pybugz/pybugz-9999.ebuild
@@ -1,15 +1,17 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/pybugz/pybugz-9999.ebuild,v 1.10 2012/03/02 08:11:33 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/pybugz/pybugz-9999.ebuild,v 1.11 2013/02/07 08:06:06 williamh Exp $
EAPI=3
PYTHON_DEPEND="2:2.7"
+RESTRICT_PYTHON_ABIS="2.[56]"
+SUPPORT_PYTHON_ABIS="1"
PYTHON_MODNAME="bugz"
PYTHON_USE_WITH="readline"
if [ "${PV}" = "9999" ]; then
EGIT_REPO_URI="git://github.com/williamh/pybugz.git"
- vcs=git-2
+ inherit git-2
else
SRC_URI="http://www.github.com/williamh/${PN}/tarball/${PV} -> ${P}.tar.gz"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~ppc-aix ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
@@ -17,7 +19,7 @@ else
S="${WORKDIR}/williamh-pybugz-${GITHUB_COMMIT}"
fi
-inherit $vcs bash-completion-r1 distutils
+inherit bash-completion-r1 distutils
DESCRIPTION="Command line interface to (Gentoo) Bugzilla"
HOMEPAGE="http://www.github.com/williamh/pybugz"
@@ -28,16 +30,10 @@ IUSE="zsh-completion"
RDEPEND="${DEPEND}
zsh-completion? ( app-shells/zsh )"
-DOCS="bugzrc.example"
-
-pkg_setup() {
- python_set_active_version 2.7
-}
-
-src_install() {
+src_install()
+{
distutils_src_install
- doman man/bugz.1
newbashcomp contrib/bash-completion bugz
if use zsh-completion ; then