summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2007-01-19 21:02:01 +0000
committerRaúl Porcel <armin76@gentoo.org>2007-01-19 21:02:01 +0000
commit47790039dcdcb07700855cdee02f3842b5b5a7f2 (patch)
tree33d27a55b2ecd1a200759a6a5ea6252796cd422c /www-misc/wsmake/wsmake-0.6.4.ebuild
parentStable on x86, bug #162603. (diff)
downloadhistorical-47790039dcdcb07700855cdee02f3842b5b5a7f2.tar.gz
historical-47790039dcdcb07700855cdee02f3842b5b5a7f2.tar.bz2
historical-47790039dcdcb07700855cdee02f3842b5b5a7f2.zip
Fix bug 148224, thanks to James Rowe <jnrowe at ukfsn dot org> for the initial patch && add metadata.xml
Package-Manager: portage-2.1.2-r1
Diffstat (limited to 'www-misc/wsmake/wsmake-0.6.4.ebuild')
-rw-r--r--www-misc/wsmake/wsmake-0.6.4.ebuild31
1 files changed, 13 insertions, 18 deletions
diff --git a/www-misc/wsmake/wsmake-0.6.4.ebuild b/www-misc/wsmake/wsmake-0.6.4.ebuild
index d13460e202ef..62398beab36e 100644
--- a/www-misc/wsmake/wsmake-0.6.4.ebuild
+++ b/www-misc/wsmake/wsmake-0.6.4.ebuild
@@ -1,40 +1,35 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-misc/wsmake/wsmake-0.6.4.ebuild,v 1.3 2004/11/06 16:23:13 pyrania Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-misc/wsmake/wsmake-0.6.4.ebuild,v 1.4 2007/01/19 21:02:01 armin76 Exp $
+
+inherit eutils
DESCRIPTION="Website Pre-processor"
HOMEPAGE="http://www.wsmake.org/"
-SRC_URI="http://ftp.wsmake.org/pub/wsmake6/stable/wsmake-0.6.4.tar.bz2
-http://ftp.wsmake.org/pub/wsmake6/docs/user-manual.pdf
-http://ftp.wsmake.org/pub/wsmake6/docs/user-manual.ps
-http://ftp.wsmake.org/pub/wsmake6/docs/user-manual-html.tar.gz"
+SRC_URI="http://ftp.wsmake.org/pub/wsmake6/stable/wsmake-0.6.4.tar.bz2"
KEYWORDS="x86"
-LICENSE="GPL-2"
+LICENSE="GPL-2 Artistic"
SLOT="0"
IUSE=""
src_unpack () {
- unpack ${P}.tar.bz2
- cd ${S}
+ unpack ${A} && cd "${S}"
#Apply patch to allow compiling
- epatch ${FILESDIR}/${P}-bv.diff || die "epatch failed."
- unpack user-manual-html.tar.gz
+ epatch "${FILESDIR}/${P}-bv.diff" || die "epatch failed."
}
src_compile () {
- ./configure --prefix=/usr || die
- emake || die
+ econf || die "econf failed"
+ emake || die "emake failed"
cd doc
tar -cf examples.tar examples || die
}
src_install () {
- make DESTDIR=${D} install || die
- dodoc AUTHORS Artistic COPYING ChangeLog* DEVELOPERS LICENSE NEWS README TODO
- cd user-manual
- dohtml * stylesheet-images/*
- cd ../doc
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS COPYING ChangeLog* DEVELOPERS LICENSE NEWS README TODO
+ cd doc
dodoc manual.txt examples.tar
}