summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2009-07-21 15:05:38 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2009-07-21 15:05:38 +0000
commite1517821273b866ecd5f3c6ce1b0446e6ead7be6 (patch)
tree6bd0b55ce1578336b47137c9ecf67d0c8c6c435c /www-plugins/noscript/noscript-1.8.8.ebuild
parentMarked stable on AMD64 as requested by Arfrever Frehtes Taifersar Arahesis <a... (diff)
downloadhistorical-e1517821273b866ecd5f3c6ce1b0446e6ead7be6.tar.gz
historical-e1517821273b866ecd5f3c6ce1b0446e6ead7be6.tar.bz2
historical-e1517821273b866ecd5f3c6ce1b0446e6ead7be6.zip
pkgmove from x11-plugins/ to www-plugins/
Package-Manager: portage-2.2_rc33/cvs/Linux i686 RepoMan-Options: --force
Diffstat (limited to 'www-plugins/noscript/noscript-1.8.8.ebuild')
-rw-r--r--www-plugins/noscript/noscript-1.8.8.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/www-plugins/noscript/noscript-1.8.8.ebuild b/www-plugins/noscript/noscript-1.8.8.ebuild
new file mode 100644
index 000000000000..2cabea5cf6dc
--- /dev/null
+++ b/www-plugins/noscript/noscript-1.8.8.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/noscript/noscript-1.8.8.ebuild,v 1.1 2009/07/21 15:05:38 nirbheek Exp $
+
+inherit mozextension multilib
+
+DESCRIPTION="Firefox plugin to disable javascript"
+HOMEPAGE="http://noscript.net/"
+SRC_URI="http://software.informaction.com/data/releases/${P}.xpi"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sparc x86"
+IUSE=""
+
+RDEPEND="|| (
+ >=www-client/mozilla-firefox-bin-1.5.0.7
+ >=www-client/mozilla-firefox-1.5.0.7
+)"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}
+
+src_unpack() {
+ xpi_unpack "${P}".xpi
+}
+
+src_install() {
+ declare MOZILLA_FIVE_HOME
+ if has_version '>=www-client/mozilla-firefox-1.5.0.7'; then
+ MOZILLA_FIVE_HOME="/usr/$(get_libdir)/mozilla-firefox"
+ xpi_install "${S}"/"${P}"
+ fi
+ if has_version '>=www-client/mozilla-firefox-bin-1.5.0.7'; then
+ MOZILLA_FIVE_HOME="/opt/firefox"
+ xpi_install "${S}"/"${P}"
+ fi
+}