summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2007-04-19 09:33:11 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2007-04-19 09:33:11 +0000
commit332fb7aa42d26f8c551657b72d415d048059b67c (patch)
tree25a97c9bca6078026118eccf4917e3e443e01563 /www-servers/bozohttpd/bozohttpd-20060517.ebuild
parentversion bump. Improved initscript thanks to inspiration by Natanael Copa in b... (diff)
downloadhistorical-332fb7aa42d26f8c551657b72d415d048059b67c.tar.gz
historical-332fb7aa42d26f8c551657b72d415d048059b67c.tar.bz2
historical-332fb7aa42d26f8c551657b72d415d048059b67c.zip
Version bump + modifications not to depend on hardcoded /bin/install; see bug #171035
Package-Manager: portage-2.1.2.2
Diffstat (limited to 'www-servers/bozohttpd/bozohttpd-20060517.ebuild')
-rw-r--r--www-servers/bozohttpd/bozohttpd-20060517.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/www-servers/bozohttpd/bozohttpd-20060517.ebuild b/www-servers/bozohttpd/bozohttpd-20060517.ebuild
new file mode 100644
index 000000000000..70b71c6e1230
--- /dev/null
+++ b/www-servers/bozohttpd/bozohttpd-20060517.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/bozohttpd/bozohttpd-20060517.ebuild,v 1.1 2007/04/19 09:33:11 s4t4n Exp $
+
+inherit eutils
+
+DESCRIPTION="bozohttpd is a small and secure http server"
+HOMEPAGE="http://www.eterna.com.au/bozohttpd/"
+SRC_URI="http://www.eterna.com.au/bozohttpd/${P}.tar.bz2"
+KEYWORDS="~x86 ~ppc"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+DEPEND=">=dev-libs/openssl-0.9.8d
+ >=sys-apps/sed-4.1.5"
+
+src_unpack()
+{
+ unpack ${A}
+ cd ${S}
+
+ # Rename Makefile
+ mv Makefile.boot Makefile
+
+ # Make it honour Gentoo CFLAGS
+ sed -ie "s/-O/${CFLAGS}/" Makefile
+}
+
+src_install ()
+{
+ dobin bozohttpd
+ doman bozohttpd.8
+
+ insinto /etc/conf.d; newins ${FILESDIR}/${PN}.conffile bozohttpd
+ exeinto /etc/init.d; newexe ${FILESDIR}/${PN}.initscript bozohttpd
+}
+
+pkg_postinst()
+{
+ einfo "Remember to edit /etc/conf.d/bozohttpd to suit your needs."
+}