summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJose Alberto Suarez Lopez <bass@gentoo.org>2005-05-16 19:09:32 +0000
committerJose Alberto Suarez Lopez <bass@gentoo.org>2005-05-16 19:09:32 +0000
commit216881212a0c32fd5593e4d4937e416dad8e22c4 (patch)
treeca2554aeadbde0894c1a809caa89b986022f74df /www-servers/cherokee/cherokee-0.4.22.ebuild
parentKeyworded ~sparc (diff)
downloadhistorical-216881212a0c32fd5593e4d4937e416dad8e22c4.tar.gz
historical-216881212a0c32fd5593e4d4937e416dad8e22c4.tar.bz2
historical-216881212a0c32fd5593e4d4937e416dad8e22c4.zip
new version and new ebuild :)
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'www-servers/cherokee/cherokee-0.4.22.ebuild')
-rw-r--r--www-servers/cherokee/cherokee-0.4.22.ebuild68
1 files changed, 68 insertions, 0 deletions
diff --git a/www-servers/cherokee/cherokee-0.4.22.ebuild b/www-servers/cherokee/cherokee-0.4.22.ebuild
new file mode 100644
index 000000000000..f853d3f21705
--- /dev/null
+++ b/www-servers/cherokee/cherokee-0.4.22.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/cherokee/cherokee-0.4.22.ebuild,v 1.1 2005/05/16 19:09:32 bass Exp $
+
+inherit eutils
+
+DESCRIPTION="An extremely fast and tiny web server."
+SRC_URI="http://www.0x50.org/download/${PV%.*}/${PV}/${P}.tar.gz"
+HOMEPAGE="http://www.0x50.org/"
+LICENSE="GPL-2"
+
+RDEPEND="virtual/libc
+ >=sys-libs/zlib-1.1.4-r1"
+
+DEPEND=">=sys-devel/automake-1.7.5
+ gnutls? ( net-libs/gnutls )
+ ssl? ( dev-libs/openssl )
+ ${RDEPEND}"
+
+KEYWORDS="~x86 ~ppc ~sparc"
+SLOT="0"
+IUSE="ipv6 ssl gnutls pic static"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/cherokee-0.4.21-no-handler_admin.diff
+}
+
+src_compile() {
+ local myconf
+
+ if use ssl && use gnutls ; then
+ myconf="${myconf} --enable-ssl=gnutls"
+ elif use ssl && ! use gnutls ; then
+ myconf="${myconf} --enable-ssl=openssl"
+ else
+ myconf="${myconf} --disable-ssl"
+ fi
+ if use pic ; then
+ myconf="${myconf} --with-pic"
+ fi
+ if ! use ipv6 ; then
+ myconf="${myconf} --disable-ipv6"
+ fi
+ if ! use static ; then
+ myconf="${myconf} --disable-static"
+ fi
+
+ econf \
+ ${myconf} \
+ --with-wwwroot=/var/www/localhost/htdocs \
+ --enable-os-string="Gentoo Linux" \
+ || die "configure failed"
+
+ emake || die "emake failed"
+}
+
+src_install () {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog COPYING INSTALL README
+
+ dodir /var/www/localhost/htdocs
+ dodir /var/www/localhost/cgi-bin
+
+ newinitd ${FILESDIR}/${PN}-0.4.17-init.d ${PN} || die "newinitd failed"
+}