summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKonstantin V. Arkhipov <voxus@gentoo.org>2005-08-24 08:38:44 +0000
committerKonstantin V. Arkhipov <voxus@gentoo.org>2005-08-24 08:38:44 +0000
commit981131fe7e230566a6e40f9480ce33821eaaa1ee (patch)
tree71b59d2b6442f2b6f284217e536bb43d96e06828 /www-servers/nginx
parentRev bump for new init script. Fixes #103104 (diff)
downloadhistorical-981131fe7e230566a6e40f9480ce33821eaaa1ee.tar.gz
historical-981131fe7e230566a6e40f9480ce33821eaaa1ee.tar.bz2
historical-981131fe7e230566a6e40f9480ce33821eaaa1ee.zip
* version bump
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'www-servers/nginx')
-rw-r--r--www-servers/nginx/ChangeLog7
-rw-r--r--www-servers/nginx/Manifest4
-rw-r--r--www-servers/nginx/files/digest-nginx-0.1.421
-rw-r--r--www-servers/nginx/nginx-0.1.42.ebuild68
4 files changed, 78 insertions, 2 deletions
diff --git a/www-servers/nginx/ChangeLog b/www-servers/nginx/ChangeLog
index 5c98e26c4638..19ddf8b37ce5 100644
--- a/www-servers/nginx/ChangeLog
+++ b/www-servers/nginx/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-servers/nginx
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.37 2005/08/09 15:31:00 voxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.38 2005/08/24 08:38:44 voxus Exp $
+
+*nginx-0.1.42 (24 Aug 2005)
+
+ 24 Aug 2005; Konstantin Arkhipov <voxus@gentoo.org> +nginx-0.1.42.ebuild:
+ Version bump.
09 Aug 2005; Konstantin Arkhipov <voxus@gentoo.org> -nginx-0.1.37.ebuild,
-nginx-0.1.38.ebuild, -nginx-0.1.39.ebuild, -nginx-0.1.40.ebuild,
diff --git a/www-servers/nginx/Manifest b/www-servers/nginx/Manifest
index 8c0914b0fc2e..4e28645ed1f7 100644
--- a/www-servers/nginx/Manifest
+++ b/www-servers/nginx/Manifest
@@ -1,6 +1,8 @@
+MD5 70d837c86a6a0761d65ea79d31f45b79 nginx-0.1.42.ebuild 1900
MD5 da8089ca918d40c0a8cdab5e39858a12 nginx-0.1.41.ebuild 1898
-MD5 87ef3ca3f611320ab6e5589f5891c922 ChangeLog 6641
+MD5 a68fd0cf3b868797d33d43d0aa3b2710 ChangeLog 6763
MD5 822f3c821527e6a34f23a6a92a884766 metadata.xml 220
MD5 d726deb4444f111650634a938adba396 files/digest-nginx-0.1.41 64
+MD5 0a5b3a3e823ccc6d86118bef0ad1e9e7 files/digest-nginx-0.1.42 64
MD5 d8f7e621e098b58848a6b5fb045c49c3 files/nginx 994
MD5 fecedd05099122b1f8169152e5bc9462 files/nginx.conf 1400
diff --git a/www-servers/nginx/files/digest-nginx-0.1.42 b/www-servers/nginx/files/digest-nginx-0.1.42
new file mode 100644
index 000000000000..d58768175bf9
--- /dev/null
+++ b/www-servers/nginx/files/digest-nginx-0.1.42
@@ -0,0 +1 @@
+MD5 d328cd46e0ebdd11052ec1d56713eb49 nginx-0.1.42.tar.gz 315976
diff --git a/www-servers/nginx/nginx-0.1.42.ebuild b/www-servers/nginx/nginx-0.1.42.ebuild
new file mode 100644
index 000000000000..7e1c3de00fbd
--- /dev/null
+++ b/www-servers/nginx/nginx-0.1.42.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.1.42.ebuild,v 1.1 2005/08/24 08:38:44 voxus Exp $
+
+inherit eutils
+
+DESCRIPTION="Robust, small and high performance http and reverse proxy server"
+
+HOMEPAGE="http://sysoev.ru/nginx/"
+SRC_URI="http://sysoev.ru/nginx/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug fastcgi imap pcre threads ssl zlib"
+
+DEPEND="dev-lang/perl
+ pcre? ( >=dev-libs/libpcre-4.2 )
+ ssl? ( dev-libs/openssl )
+ zlib? ( sys-libs/zlib )"
+
+src_compile() {
+ local myconf
+
+ if use threads; then
+ einfo
+ ewarn "threads support is experimental at the moment"
+ ewarn "do not use it on production systems - you've been warned"
+ einfo
+ myconf="${myconf} --with-threads"
+ fi
+
+ use fastcgi || myconf="${myconf} --without-http_fastcgi_module"
+ use zlib || myconf="${myconf} --without-http_gzip_module"
+ use pcre || myconf="${myconf} --without-pcre"
+ use debug && myconf="${myconf} --with-debug"
+ use ssl && myconf="${myconf} --with-http_ssl_module"
+ use imap && myconf="${myconf} --with-imap" # pop3/imap4 proxy support
+
+ ./configure \
+ --prefix=/usr \
+ --conf-path=/etc/${PN}/${PN}.conf \
+ --http-log-path=/var/log/${PN}/access_log \
+ --error-log-path=/var/log/${PN}/error_log \
+ --pid-path=/var/run/${PN}.pid \
+ --http-client-body-temp-path=/var/tmp/${PN}/client \
+ --http-proxy-temp-path=/var/tmp/${PN}/proxy \
+ --http-fastcgi-temp-path=/var/tmp/${PN}/fastcgi \
+ --with-md5-asm \
+ ${myconf} || die "configure failed"
+
+ emake || die "failed to compile"
+}
+
+src_install() {
+ keepdir /var/log/${PN} /var/tmp/${PN}/{client,proxy,fastcgi}
+
+ dodir /etc/${PN}
+
+ dosbin objs/nginx
+ doinitd ${FILESDIR}/nginx
+
+ insinto /etc/${PN}
+ rm conf/nginx.conf
+ doins -r conf/*
+ doins ${FILESDIR}/nginx.conf
+
+ dodoc CHANGES{,.ru} LICENSE README
+}