summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2005-08-08 06:28:13 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2005-08-08 06:28:13 +0000
commit9320443950a24564d84da3dfc93e586fdfc657b1 (patch)
tree985eef46960083a3b1d79db48f04c8de8b4a1423 /x11-apps/xsm/xsm-0.99.0.ebuild
parentversion bump (diff)
downloadhistorical-9320443950a24564d84da3dfc93e586fdfc657b1.tar.gz
historical-9320443950a24564d84da3dfc93e586fdfc657b1.tar.bz2
historical-9320443950a24564d84da3dfc93e586fdfc657b1.zip
Initial commit for modular X.
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'x11-apps/xsm/xsm-0.99.0.ebuild')
-rw-r--r--x11-apps/xsm/xsm-0.99.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/x11-apps/xsm/xsm-0.99.0.ebuild b/x11-apps/xsm/xsm-0.99.0.ebuild
new file mode 100644
index 000000000000..cd60cff9c1bd
--- /dev/null
+++ b/x11-apps/xsm/xsm-0.99.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xsm/xsm-0.99.0.ebuild,v 1.1 2005/08/08 06:28:13 spyderous Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+DESCRIPTION="X.Org xsm application"
+KEYWORDS="~x86"
+IUSE="xprint"
+RDEPEND="x11-libs/libXaw
+ net-misc/netkit-rsh"
+DEPEND="${RDEPEND}"
+
+CONFIGURE_OPTIONS="$(use_enable xprint)"
+
+pkg_setup() {
+ if use xprint && ! built_with_use x11-libs/libXaw xprint; then
+ die "Build x11-libs/libXaw with USE=xprint."
+ fi
+}