summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2011-07-01 23:55:39 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2011-07-01 23:55:39 +0000
commit597cf6445aaf3ee208457bfa0ae72ae78056eda8 (patch)
tree5916c958e18f926a896193a3a2b8545960609bd9 /x11-apps/xwininfo/xwininfo-1.1.2.ebuild
parentVersion bump. (diff)
downloadhistorical-597cf6445aaf3ee208457bfa0ae72ae78056eda8.tar.gz
historical-597cf6445aaf3ee208457bfa0ae72ae78056eda8.tar.bz2
historical-597cf6445aaf3ee208457bfa0ae72ae78056eda8.zip
Version bump.
Package-Manager: portage-2.2.0_alpha41/cvs/Linux x86_64
Diffstat (limited to 'x11-apps/xwininfo/xwininfo-1.1.2.ebuild')
-rw-r--r--x11-apps/xwininfo/xwininfo-1.1.2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/x11-apps/xwininfo/xwininfo-1.1.2.ebuild b/x11-apps/xwininfo/xwininfo-1.1.2.ebuild
new file mode 100644
index 000000000000..2b9f115575dd
--- /dev/null
+++ b/x11-apps/xwininfo/xwininfo-1.1.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xwininfo/xwininfo-1.1.2.ebuild,v 1.1 2011/07/01 23:53:48 chithanh Exp $
+
+EAPI=4
+
+inherit xorg-2 flag-o-matic
+
+DESCRIPTION="window information utility for X"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris ~x86-winnt"
+IUSE=""
+
+RDEPEND=">=x11-libs/libxcb-1.6
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ >=x11-proto/xproto-7.0.17"
+
+pkg_setup() {
+ # interix has a _very_ old iconv in libc, however, including
+ # iconv.h redefines those symbols to libiconv_*, which then
+ # are unresolved, as the configure check is old and dumb.
+ [[ ${CHOST} == *-interix* ]] &&
+ append-libs -liconv
+}