summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-05-04 12:45:09 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-05-04 12:45:09 +0000
commit1a075ab304f6430e8a4d5bd3053aa23846476522 (patch)
tree31edfce28d96f45a88d8dd9c7fe041b477168cc1 /x11-apps
parentApply correct pkgconfig patch. Should fix bug 268090 (diff)
downloadhistorical-1a075ab304f6430e8a4d5bd3053aa23846476522.tar.gz
historical-1a075ab304f6430e8a4d5bd3053aa23846476522.tar.bz2
historical-1a075ab304f6430e8a4d5bd3053aa23846476522.zip
Move use_ functions out of global scope.
Package-Manager: portage-2.1.6.12/cvs/Linux x86_64
Diffstat (limited to 'x11-apps')
-rw-r--r--x11-apps/xdpyinfo/ChangeLog6
-rw-r--r--x11-apps/xdpyinfo/xdpyinfo-1.0.2.ebuild14
-rw-r--r--x11-apps/xdpyinfo/xdpyinfo-1.0.3.ebuild12
3 files changed, 18 insertions, 14 deletions
diff --git a/x11-apps/xdpyinfo/ChangeLog b/x11-apps/xdpyinfo/ChangeLog
index fd7c4cb0bd5c..2fd6fd1b5eb9 100644
--- a/x11-apps/xdpyinfo/ChangeLog
+++ b/x11-apps/xdpyinfo/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-apps/xdpyinfo
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xdpyinfo/ChangeLog,v 1.38 2009/04/05 23:38:47 tester Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xdpyinfo/ChangeLog,v 1.39 2009/05/04 12:45:09 ssuominen Exp $
+
+ 04 May 2009; Samuli Suominen <ssuominen@gentoo.org> xdpyinfo-1.0.2.ebuild,
+ xdpyinfo-1.0.3.ebuild:
+ Move use_ functions out of global scope.
05 Apr 2009; Olivier CrĂȘte <tester@gentoo.org> xdpyinfo-1.0.3.ebuild:
amd64 stable
diff --git a/x11-apps/xdpyinfo/xdpyinfo-1.0.2.ebuild b/x11-apps/xdpyinfo/xdpyinfo-1.0.2.ebuild
index aa95cc84e7a4..455d9543d5f5 100644
--- a/x11-apps/xdpyinfo/xdpyinfo-1.0.2.ebuild
+++ b/x11-apps/xdpyinfo/xdpyinfo-1.0.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xdpyinfo/xdpyinfo-1.0.2.ebuild,v 1.11 2007/08/07 13:27:24 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xdpyinfo/xdpyinfo-1.0.2.ebuild,v 1.12 2009/05/04 12:45:09 ssuominen Exp $
# Must be before x-modular eclass is inherited
#SNAPSHOT="yes"
@@ -8,9 +8,7 @@
inherit x-modular
DESCRIPTION="display information utility for X"
-
KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
-
IUSE="dga dmx xinerama"
RDEPEND="x11-libs/libXext
@@ -35,6 +33,8 @@ DEPEND="${RDEPEND}
dmx? ( x11-proto/dmxproto )
x11-proto/printproto"
-CONFIGURE_OPTIONS="$(use_with dga)
- $(use_with dmx)
- $(use_with xinerama)"
+pkg_setup() {
+ CONFIGURE_OPTIONS="$(use_with dga)
+ $(use_with dmx)
+ $(use_with xinerama)"
+}
diff --git a/x11-apps/xdpyinfo/xdpyinfo-1.0.3.ebuild b/x11-apps/xdpyinfo/xdpyinfo-1.0.3.ebuild
index a8f1cf2c8652..c1860c1dd0a4 100644
--- a/x11-apps/xdpyinfo/xdpyinfo-1.0.3.ebuild
+++ b/x11-apps/xdpyinfo/xdpyinfo-1.0.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xdpyinfo/xdpyinfo-1.0.3.ebuild,v 1.2 2009/04/05 23:38:47 tester Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xdpyinfo/xdpyinfo-1.0.3.ebuild,v 1.3 2009/05/04 12:45:09 ssuominen Exp $
# Must be before x-modular eclass is inherited
#SNAPSHOT="yes"
@@ -8,9 +8,7 @@
inherit x-modular
DESCRIPTION="display information utility for X"
-
KEYWORDS="~alpha amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-
IUSE="dga dmx xinerama"
RDEPEND="x11-libs/libXext
@@ -35,6 +33,8 @@ DEPEND="${RDEPEND}
dmx? ( x11-proto/dmxproto )
x11-proto/printproto"
-CONFIGURE_OPTIONS="$(use_with dga)
- $(use_with dmx)
- $(use_with xinerama)"
+pkg_setup() {
+ CONFIGURE_OPTIONS="$(use_with dga)
+ $(use_with dmx)
+ $(use_with xinerama)"
+}