summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Stine <battousai@gentoo.org>2009-03-28 00:34:08 +0000
committerBryan Stine <battousai@gentoo.org>2009-03-28 00:34:08 +0000
commitbafc98e2ef6a052f749f39fb8015b5d793473bc2 (patch)
tree3fa7cfd0363d2f9e3084a33134600b21c4c8ea4a /x11-base/x11-drm/x11-drm-20090320.ebuild
parentRefactor gcc-3 stack-protector filtering a bit more (diff)
downloadhistorical-bafc98e2ef6a052f749f39fb8015b5d793473bc2.tar.gz
historical-bafc98e2ef6a052f749f39fb8015b5d793473bc2.tar.bz2
historical-bafc98e2ef6a052f749f39fb8015b5d793473bc2.zip
Remove unneeded AGP and (useless) extra DRM kernel config checks.
Package-Manager: portage-2.2_rc25/cvs/Linux x86_64
Diffstat (limited to 'x11-base/x11-drm/x11-drm-20090320.ebuild')
-rw-r--r--x11-base/x11-drm/x11-drm-20090320.ebuild10
1 files changed, 2 insertions, 8 deletions
diff --git a/x11-base/x11-drm/x11-drm-20090320.ebuild b/x11-base/x11-drm/x11-drm-20090320.ebuild
index a33e98e57af8..af458a14113d 100644
--- a/x11-base/x11-drm/x11-drm-20090320.ebuild
+++ b/x11-base/x11-drm/x11-drm-20090320.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-base/x11-drm/x11-drm-20090320.ebuild,v 1.2 2009/03/27 22:24:25 battousai Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-base/x11-drm/x11-drm-20090320.ebuild,v 1.3 2009/03/28 00:34:08 battousai Exp $
inherit eutils x11 linux-mod autotools
@@ -140,9 +140,8 @@ kernel_setup() {
die "Please use in-kernel DRM or switch to a 2.6 kernel."
fi
- CONFIG_CHECK="!DRM AGP"
+ CONFIG_CHECK="!DRM"
ERROR_DRM="Please disable DRM in the kernel config. (CONFIG_DRM = n)"
- ERROR_AGP="AGP support is not enabled in your kernel config (CONFIG_AGP)"
linux-mod_pkg_setup
fi
@@ -258,11 +257,6 @@ src_compile_linux() {
BUILD_TARGETS="modules"
BUILD_PARAMS="DRM_MODULES='${VIDCARDS}' LINUXDIR='${KERNEL_DIR}' M='${SRC_BUILD}'"
ECONF_PARAMS='' S="${SRC_BUILD}" linux-mod_src_compile
-
- if linux_chkconfig_present DRM
- then
- ewarn "Please disable in-kernel DRM support to use this package."
- fi
}
src_compile_freebsd() {