summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2005-08-08 06:37:41 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2005-08-08 06:37:41 +0000
commitfd01cb5b563269fa54510fd962377340e5e403ff (patch)
tree532efb75ab631af10f96c0e8716d76fa5ca440e9 /x11-base
parentAdd dri, which will be used by a number of X drivers and the server. (diff)
downloadhistorical-fd01cb5b563269fa54510fd962377340e5e403ff.tar.gz
historical-fd01cb5b563269fa54510fd962377340e5e403ff.tar.bz2
historical-fd01cb5b563269fa54510fd962377340e5e403ff.zip
Initial commit for modular X.
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'x11-base')
-rw-r--r--x11-base/xorg-server/ChangeLog10
-rw-r--r--x11-base/xorg-server/Manifest4
-rw-r--r--x11-base/xorg-server/files/digest-xorg-server-0.99.12
-rw-r--r--x11-base/xorg-server/files/xorg-composite.patch66
-rw-r--r--x11-base/xorg-server/xorg-server-0.99.1.ebuild75
5 files changed, 157 insertions, 0 deletions
diff --git a/x11-base/xorg-server/ChangeLog b/x11-base/xorg-server/ChangeLog
new file mode 100644
index 000000000000..4c3471d611f6
--- /dev/null
+++ b/x11-base/xorg-server/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for x11-base/xorg-server
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-base/xorg-server/ChangeLog,v 1.1 2005/08/08 06:37:41 spyderous Exp $
+
+*xorg-server-0.99.1 (08 Aug 2005)
+
+ 08 Aug 2005; Donnie Berkholz <spyderous@gentoo.org>;
+ +files/xorg-composite.patch, +xorg-server-0.99.1.ebuild:
+ Initial commit for modular X.
+
diff --git a/x11-base/xorg-server/Manifest b/x11-base/xorg-server/Manifest
new file mode 100644
index 000000000000..5f23b364545a
--- /dev/null
+++ b/x11-base/xorg-server/Manifest
@@ -0,0 +1,4 @@
+MD5 57cb9640bebb5c701919587a86d91438 xorg-server-0.99.1.ebuild 1891
+MD5 24fa45be2d1355b96fd5b22bf6ac2627 ChangeLog 398
+MD5 139d1af499d5fd30cbb118284544e3f6 files/xorg-composite.patch 2397
+MD5 44296a07d7ed76922dd604d93b00ab18 files/digest-xorg-server-0.99.1 137
diff --git a/x11-base/xorg-server/files/digest-xorg-server-0.99.1 b/x11-base/xorg-server/files/digest-xorg-server-0.99.1
new file mode 100644
index 000000000000..b4cf4fc553af
--- /dev/null
+++ b/x11-base/xorg-server/files/digest-xorg-server-0.99.1
@@ -0,0 +1,2 @@
+MD5 ae556a5fa66cb9871cd9eb93bcc908ad xorg-server-0.99.1.tar.bz2 3602415
+MD5 9e05f987ec79f6374457bea343b063c2 Mesa-6.3.1.1.tar.gz 6379711
diff --git a/x11-base/xorg-server/files/xorg-composite.patch b/x11-base/xorg-server/files/xorg-composite.patch
new file mode 100644
index 000000000000..a0b466b67808
--- /dev/null
+++ b/x11-base/xorg-server/files/xorg-composite.patch
@@ -0,0 +1,66 @@
+1. Make composite build for Xnest and Xorg by fixing link order
+2. Make Xdmx link properly when building the module with composite
+3. Fix typo of XF86MIS instead of XF86MISC
+4. Require glproto for dmx/glxproxy and for dri+glx
+
+Index: xorg/configure.ac
+===================================================================
+RCS file: /cvs/xorg/xserver/xorg/configure.ac,v
+retrieving revision 1.30
+diff -u -b -B -r1.30 configure.ac
+--- xorg/configure.ac 27 Jul 2005 08:11:26 -0000 1.30
++++ xorg/configure.ac 28 Jul 2005 20:49:35 -0000
+@@ -221,6 +221,9 @@
+ if test "$DMX" = yes; then
+ PKG_CHECK_MODULES([DMXMODULES],
+ [xmuu xext x11 xrender xfont xi dmxproto])
++ if test "$GLX" = yes; then
++ PKG_CHECK_MODULES([GL],[glproto])
++ fi
+ fi
+ AM_CONDITIONAL(DMX, [test x$DMX = xyes])
+
+@@ -404,6 +407,9 @@
+ AC_SUBST(DRIPROTO_CFLAGS)
+ PKG_CHECK_MODULES([LIBDRM], [libdrm])
+ AC_SUBST(LIBDRM_CFLAGS)
++ if test "$GLX" = yes; then
++ PKG_CHECK_MODULES([GL],[glproto])
++ fi
+ fi
+ AC_DEFINE(XINPUT,1,[Support X Input extension])
+ EXTENSION_LIBS="$EXTENSION_LIBS "'$(top_builddir)/Xi/libXi.la'
+@@ -541,7 +547,7 @@
+ if test x$XF86VIDMODE = xyes; then
+ AC_DEFINE(XF86VIDMODE,1,[Support XFree86 Video Mode extension])
+ fi
+-if test x$XF86MIS = xyes; then
++if test x$XF86MISC = xyes; then
+ AC_DEFINE(XF86MISC,1,[Support XFree86 miscellaneous extensions])
+ fi
+ # must come first as it uses stuff in Shape -d
+@@ -574,11 +574,6 @@
+ EXTENSION_LIBS="$EXTENSION_LIBS "'$(top_builddir)/damageext/libdamageext.la'
+ EXTENSION_INCS="$EXTENSION_INCS "'-I$(top_srcdir)/damageext'
+
+-if test "$COMPOSITE" = yes; then
+- EXTENSION_LIBS="$EXTENSION_LIBS "'$(top_builddir)/composite/libcomposite.la'" "'$(top_builddir)/miext/cw/libcw.la'
+- EXTENSION_INCS="$EXTENSION_INCS "'-I$(top_srcdir)/composite'
+-fi
+-
+ DIX_LIB='$(top_builddir)/dix/libdix.la'
+ OS_LIB='$(top_builddir)/os/libos.la'
+ MI_LIB='$(top_builddir)/mi/libmi.la'
+@@ -598,6 +593,12 @@
+ XI_INC='-I$(top_srcdir)/Xi'
+ CORE_INCS='-I$(top_srcdir)/include -I$(top_builddir)/include'
+
++if test "$COMPOSITE" = yes; then
++ EXTENSION_LIBS="$EXTENSION_LIBS "'$(top_builddir)/composite/libcomposite.la'
++ DAMAGE_LIB="$DAMAGE_LIB "'$(top_builddir)/miext/cw/libcw.la'
++ EXTENSION_INCS="$EXTENSION_INCS "'-I$(top_srcdir)/composite'" "'-I$(top_srcdir)/miext/cw'
++fi
++
+ PKG_CHECK_MODULES([XSERVER], [$REQUIRED_MODULES])
+ XSERVER_LIBS="${XSERVER_LIBS} -lm -lz"
+
diff --git a/x11-base/xorg-server/xorg-server-0.99.1.ebuild b/x11-base/xorg-server/xorg-server-0.99.1.ebuild
new file mode 100644
index 000000000000..010f89251c0b
--- /dev/null
+++ b/x11-base/xorg-server/xorg-server-0.99.1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-base/xorg-server/xorg-server-0.99.1.ebuild,v 1.1 2005/08/08 06:37:41 spyderous Exp $
+
+# Must be before x-modular eclass is inherited
+# Hack to make sure autoreconf gets run
+SNAPSHOT="yes"
+
+inherit x-modular
+
+MESA_PN="Mesa"
+MESA_PV="6.3.1.1"
+MESA_P="${MESA_PN}-${MESA_PV}"
+
+PATCHES="${FILESDIR}/xorg-composite.patch"
+
+SRC_URI="${SRC_URI}
+ glx? ( http://xorg.freedesktop.org/extras/${MESA_P}.tar.gz )"
+DESCRIPTION="X.Org X servers"
+KEYWORDS="~x86"
+IUSE="glx dri xinerama ipv6 minimal"
+RDEPEND="x11-libs/libXfont
+ x11-libs/xtrans
+ x11-libs/libXau
+ x11-libs/libXext
+ x11-libs/libX11
+ x11-libs/libxkbfile
+ x11-libs/libXdmcp
+ x11-libs/libXmu
+ x11-libs/libXrender
+ x11-libs/libXi
+ media-libs/freetype"
+DEPEND="${RDEPEND}
+ x11-proto/randrproto
+ x11-proto/renderproto
+ x11-proto/fixesproto
+ x11-proto/damageproto
+ x11-proto/xextproto
+ x11-proto/xproto
+ x11-proto/xf86dgaproto
+ x11-proto/xf86miscproto
+ x11-proto/xf86rushproto
+ x11-proto/xf86vidmodeproto
+ x11-proto/xf86bigfontproto
+ x11-proto/compositeproto
+ x11-proto/recordproto
+ x11-proto/resourceproto
+ x11-proto/dmxproto
+ xinerama? ( x11-proto/panoramixproto )
+ glx? ( x11-proto/glproto )
+ dri? ( x11-proto/xf86driproto
+ x11-libs/libdrm )"
+
+if use glx; then
+ confopts="${confopts} --with-mesa-source=${WORKDIR}/${MESA_P}"
+fi
+
+# localstatedir is used for the log location; we need to override the default
+# from ebuild.sh
+# sysconfdir is used for the xorg.conf location; same applies
+CONFIGURE_OPTIONS="
+ $(use_enable xinerama)
+ $(use_enable ipv6)
+ $(use_enable !minimal dmx)
+ $(use_enable !minimal xvfb)
+ $(use_enable !minimal xnest)
+ $(use_enable glx)
+ $(use_enable dri)
+ --enable-xorg
+ --enable-composite
+ --enable-xtrap
+ --enable-xevie
+ --sysconfdir=/etc/X11
+ --localstatedir=/var
+ ${confopts}"