summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2009-08-03 00:47:34 +0000
committerDoug Goldstein <cardoe@gentoo.org>2009-08-03 00:47:34 +0000
commit7255eba1e13d3fe853b6a4e526d9f7c420883ffe (patch)
tree04c4d1a88633cf7b4d9890964a9c0e138be050db /x11-drivers/nvidia-drivers/nvidia-drivers-185.18.14.ebuild
parentMake --use-old work again, thanks to Brian Childs <brian AT rentec DOT com>; ... (diff)
downloadhistorical-7255eba1e13d3fe853b6a4e526d9f7c420883ffe.tar.gz
historical-7255eba1e13d3fe853b6a4e526d9f7c420883ffe.tar.bz2
historical-7255eba1e13d3fe853b6a4e526d9f7c420883ffe.zip
remove paravirt check again. bug #264375 again
Package-Manager: portage-2.1.6.13/cvs/Linux x86_64
Diffstat (limited to 'x11-drivers/nvidia-drivers/nvidia-drivers-185.18.14.ebuild')
-rw-r--r--x11-drivers/nvidia-drivers/nvidia-drivers-185.18.14.ebuild20
1 files changed, 1 insertions, 19 deletions
diff --git a/x11-drivers/nvidia-drivers/nvidia-drivers-185.18.14.ebuild b/x11-drivers/nvidia-drivers/nvidia-drivers-185.18.14.ebuild
index b6856c3f78c0..5bbc1cec498b 100644
--- a/x11-drivers/nvidia-drivers/nvidia-drivers-185.18.14.ebuild
+++ b/x11-drivers/nvidia-drivers/nvidia-drivers-185.18.14.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/nvidia-drivers/nvidia-drivers-185.18.14.ebuild,v 1.1 2009/07/25 06:11:53 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/nvidia-drivers/nvidia-drivers-185.18.14.ebuild,v 1.2 2009/08/03 00:47:30 cardoe Exp $
inherit eutils multilib versionator linux-mod flag-o-matic nvidia-driver
@@ -159,23 +159,6 @@ mtrr_check() {
fi
}
-paravirt_check() {
- ebegin "Checking for Paravirtualized guest support"
- linux_chkconfig_present PARAVIRT_GUEST
-
- if [[ $? -eq 0 ]]; then
- eerror "Please disable PARAVIRT_GUEST in your kernel config, found at:"
- eerror
- eerror " Processor type and features"
- eerror " [*] Paravirtualized guest support"
- eerror
- eerror "or XEN support"
- eerror
- eerror "and recompile your kernel .."
- die "PARAVIRT_GUEST support detected!"
- fi
-}
-
pkg_setup() {
# try to turn off distcc and ccache for people that have a problem with it
export DISTCC_DISABLE=1
@@ -192,7 +175,6 @@ pkg_setup() {
BUILD_PARAMS="IGNORE_CC_MISMATCH=yes V=1 SYSSRC=${KV_DIR} \
SYSOUT=${KV_OUT_DIR} HOST_CC=$(tc-getBUILD_CC)"
mtrr_check
- paravirt_check
fi
# On BSD userland it wants real make command