summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2006-07-14 22:26:46 +0000
committerSeemant Kulleen <seemant@gentoo.org>2006-07-14 22:26:46 +0000
commit0cbd3cca23abb1e78c94a1d1fd2e068cd4ecfe03 (patch)
treee1dc8c49c64aad094b361e514fcc5d99c7380ad2 /x11-drivers
parentfix with 2.4 thanks to Christophe Garault <gentoo@garault.org> in bug 140375,... (diff)
downloadhistorical-0cbd3cca23abb1e78c94a1d1fd2e068cd4ecfe03.tar.gz
historical-0cbd3cca23abb1e78c94a1d1fd2e068cd4ecfe03.tar.bz2
historical-0cbd3cca23abb1e78c94a1d1fd2e068cd4ecfe03.zip
fix the build system to not install into /usr/local. I really should not be checking version bumps in with such a hurry (ironic given how long the ebuild languished in bugzilla). Anyway, this fixes the install location of the binaries and the man pages. Closes bug #140388 by Martin Wegner
Package-Manager: portage-2.1.1_pre2-r8
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/synaptics/ChangeLog11
-rw-r--r--x11-drivers/synaptics/files/digest-synaptics-0.14.5-r13
-rw-r--r--x11-drivers/synaptics/synaptics-0.14.5-r1.ebuild57
3 files changed, 70 insertions, 1 deletions
diff --git a/x11-drivers/synaptics/ChangeLog b/x11-drivers/synaptics/ChangeLog
index 6ee2584d96d3..fa5cbd6318a4 100644
--- a/x11-drivers/synaptics/ChangeLog
+++ b/x11-drivers/synaptics/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for x11-drivers/synaptics
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/synaptics/ChangeLog,v 1.12 2006/07/12 14:11:44 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/synaptics/ChangeLog,v 1.13 2006/07/14 22:26:46 seemant Exp $
+
+*synaptics-0.14.5-r1 (14 Jul 2006)
+
+ 14 Jul 2006; Seemant Kulleen <seemant@gentoo.org>
+ -synaptics-0.14.5.ebuild, +synaptics-0.14.5-r1.ebuild:
+ fix the build system to not install into /usr/local. I really should not be
+ checking version bumps in with such a hurry (ironic given how long the
+ ebuild languished in bugzilla). Anyway, this fixes the install location of
+ the binaries and the man pages. Closes bug #140388 by Martin Wegner
*synaptics-0.14.5 (12 Jul 2006)
diff --git a/x11-drivers/synaptics/files/digest-synaptics-0.14.5-r1 b/x11-drivers/synaptics/files/digest-synaptics-0.14.5-r1
new file mode 100644
index 000000000000..9bc140596c4e
--- /dev/null
+++ b/x11-drivers/synaptics/files/digest-synaptics-0.14.5-r1
@@ -0,0 +1,3 @@
+MD5 aab6dc3f18344cdac7ef16e441cdc2c7 synaptics-0.14.5.tar.bz2 126743
+RMD160 815e95e3ae2ef2e60b55b7023e27619ca8c18893 synaptics-0.14.5.tar.bz2 126743
+SHA256 aaad8ee83d5c6fd1e46be7201086645bd271281843751f850d345c7a9545b796 synaptics-0.14.5.tar.bz2 126743
diff --git a/x11-drivers/synaptics/synaptics-0.14.5-r1.ebuild b/x11-drivers/synaptics/synaptics-0.14.5-r1.ebuild
new file mode 100644
index 000000000000..e4c5b27c153e
--- /dev/null
+++ b/x11-drivers/synaptics/synaptics-0.14.5-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/synaptics/synaptics-0.14.5-r1.ebuild,v 1.1 2006/07/14 22:26:46 seemant Exp $
+
+inherit toolchain-funcs eutils
+
+IUSE="dlloader"
+
+DESCRIPTION="Driver for Synaptics touchpads"
+HOMEPAGE="http://w1.894.telia.com/~u89404340/touchpad/"
+SRC_URI="http://w1.894.telia.com/~u89404340/touchpad/files/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+RDEPEND="|| ( x11-libs/libXext virtual/x11 )"
+DEPEND="${RDEPEND}
+ || ( x11-base/xorg-server virtual/x11 )
+ >=sys-apps/sed-4"
+
+src_unpack() {
+ unpack ${A} ; cd ${S}
+
+ if use dlloader || has_version ">=x11-base/xorg-x11-6.8.99.15" || has_version ">=x11-base/xorg-server-0.99"
+ then
+ epatch ${FILESDIR}/${PF}-makefile-fpic.patch
+ fi
+
+ # Compilation fix for xorg-7.1
+ epatch ${FILESDIR}/${P}-xorg-7.1-compile-fix.patch
+
+ # Switch up the CC and CFLAGS stuff.
+ sed -i \
+ -e "s:CC = gcc:CC = $(tc-getCC):g" \
+ -e "s:CDEBUGFLAGS = -O2:CDEBUGFLAGS = ${CFLAGS}:g" \
+ ${S}/Makefile
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ make \
+ DESTDIR=${D} \
+ PREFIX=/usr \
+ MANDIR=${D}/usr/share \
+ install || die
+
+ dodoc script/usbmouse script/usbhid alps.patch trouble-shooting.txt
+ dodoc COMPATIBILITY FILES INSTALL* LICENSE NEWS TODO README*
+
+ # Stupid new daemon, didn't work for me because of shm issues
+ newinitd ${FILESDIR}/rc.init syndaemon
+ newconfd ${FILESDIR}/rc.conf syndaemon
+}