summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2012-07-27 23:00:34 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2012-07-27 23:00:34 +0000
commitae25b826492bcd1817c28195f00c54790345a2f3 (patch)
tree980fed5b8040b3558bf4a44ba84e01a3bcfbd077 /x11-drivers
parentSwitch from yasm to gcc for assembler to support all arches (diff)
downloadhistorical-ae25b826492bcd1817c28195f00c54790345a2f3.tar.gz
historical-ae25b826492bcd1817c28195f00c54790345a2f3.tar.bz2
historical-ae25b826492bcd1817c28195f00c54790345a2f3.zip
Version bump.
Package-Manager: portage-2.2.0_alpha115/cvs/Linux x86_64
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xf86-input-mouse/ChangeLog9
-rw-r--r--x11-drivers/xf86-input-mouse/xf86-input-mouse-1.8.0.ebuild14
-rw-r--r--x11-drivers/xf86-video-intel/ChangeLog8
-rw-r--r--x11-drivers/xf86-video-intel/xf86-video-intel-2.20.2.ebuild54
4 files changed, 82 insertions, 3 deletions
diff --git a/x11-drivers/xf86-input-mouse/ChangeLog b/x11-drivers/xf86-input-mouse/ChangeLog
index 637915e3cf07..9d01ca6047a8 100644
--- a/x11-drivers/xf86-input-mouse/ChangeLog
+++ b/x11-drivers/xf86-input-mouse/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-drivers/xf86-input-mouse
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-mouse/ChangeLog,v 1.121 2012/07/12 17:29:23 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-mouse/ChangeLog,v 1.122 2012/07/27 22:58:09 chithanh Exp $
+
+*xf86-input-mouse-1.8.0 (27 Jul 2012)
+
+ 27 Jul 2012; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +xf86-input-mouse-1.8.0.ebuild:
+ Version bump.
12 Jul 2012; Brent Baude <ranger@gentoo.org> xf86-input-mouse-1.7.2.ebuild:
Marking xf86-input-mouse-1.7.2 ppc stable for bug 419473
@@ -515,4 +521,3 @@
08 Aug 2005; Donnie Berkholz <dberkholz@gentoo.org>;
+xf86-input-mouse-1.0.0.ebuild:
Initial commit for modular X.
-
diff --git a/x11-drivers/xf86-input-mouse/xf86-input-mouse-1.8.0.ebuild b/x11-drivers/xf86-input-mouse/xf86-input-mouse-1.8.0.ebuild
new file mode 100644
index 000000000000..e54db2130a1d
--- /dev/null
+++ b/x11-drivers/xf86-input-mouse/xf86-input-mouse-1.8.0.ebuild
@@ -0,0 +1,14 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-mouse/xf86-input-mouse-1.8.0.ebuild,v 1.1 2012/07/27 22:58:09 chithanh Exp $
+
+EAPI=4
+inherit xorg-2
+
+DESCRIPTION="X.Org driver for mouse input devices"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=x11-base/xorg-server-1.7"
+DEPEND="${RDEPEND}"
diff --git a/x11-drivers/xf86-video-intel/ChangeLog b/x11-drivers/xf86-video-intel/ChangeLog
index db871af960cc..b729491c340b 100644
--- a/x11-drivers/xf86-video-intel/ChangeLog
+++ b/x11-drivers/xf86-video-intel/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-drivers/xf86-video-intel
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-intel/ChangeLog,v 1.93 2012/07/23 12:01:52 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-intel/ChangeLog,v 1.94 2012/07/27 23:00:34 chithanh Exp $
+
+*xf86-video-intel-2.20.2 (27 Jul 2012)
+
+ 27 Jul 2012; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +xf86-video-intel-2.20.2.ebuild:
+ Version bump.
*xf86-video-intel-2.20.1 (23 Jul 2012)
diff --git a/x11-drivers/xf86-video-intel/xf86-video-intel-2.20.2.ebuild b/x11-drivers/xf86-video-intel/xf86-video-intel-2.20.2.ebuild
new file mode 100644
index 000000000000..f22ccc6f74e9
--- /dev/null
+++ b/x11-drivers/xf86-video-intel/xf86-video-intel-2.20.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-intel/xf86-video-intel-2.20.2.ebuild,v 1.1 2012/07/27 23:00:34 chithanh Exp $
+
+EAPI=4
+
+XORG_DRI=dri
+inherit linux-info xorg-2
+
+DESCRIPTION="X.Org driver for Intel cards"
+
+KEYWORDS="~amd64 ~ia64 ~x86 ~amd64-fbsd -x86-fbsd"
+IUSE="glamor +sna"
+
+RDEPEND="x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXvMC
+ >=x11-libs/libxcb-1.5
+ x11-libs/xcb-util
+ >=x11-libs/libdrm-2.4.29[video_cards_intel]
+ glamor? (
+ x11-libs/glamor
+ )
+ sna? (
+ >=x11-base/xorg-server-1.10
+ >=x11-libs/pixman-0.23
+ )"
+DEPEND="${RDEPEND}
+ >=x11-proto/dri2proto-2.6"
+
+src_configure() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable dri)
+ $(use_enable glamor)
+ $(use_enable sna)
+ --enable-xvmc
+ )
+ xorg-2_src_configure
+}
+
+pkg_postinst() {
+ if linux_config_exists \
+ && ! linux_chkconfig_present DRM_I915_KMS; then
+ echo
+ ewarn "This driver requires KMS support in your kernel"
+ ewarn " Device Drivers --->"
+ ewarn " Graphics support --->"
+ ewarn " Direct Rendering Manager (XFree86 4.1.0 and higher DRI support) --->"
+ ewarn " <*> Intel 830M, 845G, 852GM, 855GM, 865G (i915 driver) --->"
+ ewarn " i915 driver"
+ ewarn " [*] Enable modesetting on intel by default"
+ echo
+ fi
+}