summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2009-04-10 15:09:03 +0000
committerBen de Groot <yngwin@gentoo.org>2009-04-10 15:09:03 +0000
commit4785f8a02f3c71e56d2bfe369085e05f57fd373b (patch)
tree9dfae0936d1f95a355312b63d792e791767cc1ff /x11-libs/fltk
parentsparc/x86 stable wrt #263795 (diff)
downloadhistorical-4785f8a02f3c71e56d2bfe369085e05f57fd373b.tar.gz
historical-4785f8a02f3c71e56d2bfe369085e05f57fd373b.tar.bz2
historical-4785f8a02f3c71e56d2bfe369085e05f57fd373b.zip
Version bump to latest snapshot. Drop old. Add patch for missing C includes.
Package-Manager: portage-2.2_rc28/cvs/Linux x86_64
Diffstat (limited to 'x11-libs/fltk')
-rw-r--r--x11-libs/fltk/ChangeLog9
-rw-r--r--x11-libs/fltk/files/fltk2-gcc43.patch20
-rw-r--r--x11-libs/fltk/fltk-2.0_pre6671.ebuild (renamed from x11-libs/fltk/fltk-2.0_pre6525.ebuild)15
3 files changed, 36 insertions, 8 deletions
diff --git a/x11-libs/fltk/ChangeLog b/x11-libs/fltk/ChangeLog
index 84b113882433..707a8d351976 100644
--- a/x11-libs/fltk/ChangeLog
+++ b/x11-libs/fltk/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-libs/fltk
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/fltk/ChangeLog,v 1.112 2009/02/24 12:51:27 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/fltk/ChangeLog,v 1.113 2009/04/10 15:09:02 yngwin Exp $
+
+*fltk-2.0_pre6671 (10 Apr 2009)
+
+ 10 Apr 2009; Ben de Groot <yngwin@gentoo.org> +files/fltk2-gcc43.patch,
+ -fltk-2.0_pre6525.ebuild, +fltk-2.0_pre6671.ebuild:
+ Version bump to latest snapshot. Drop old. Add patch for missing C
+ includes.
24 Feb 2009; Raúl Porcel <armin76@gentoo.org> fltk-1.1.7-r2.ebuild,
fltk-1.1.7-r3.ebuild, fltk-1.1.9.ebuild, fltk-2.0_pre6525.ebuild:
diff --git a/x11-libs/fltk/files/fltk2-gcc43.patch b/x11-libs/fltk/files/fltk2-gcc43.patch
new file mode 100644
index 000000000000..1165828be193
--- /dev/null
+++ b/x11-libs/fltk/files/fltk2-gcc43.patch
@@ -0,0 +1,20 @@
+--- fltk-2.0.x-r6671.orig/src/Image.cxx 2009-04-10 16:07:34.000000000 +0200
++++ fltk-2.0.x-r6671/src/Image.cxx 2009-04-10 16:03:22.000000000 +0200
+@@ -20,6 +20,7 @@
+ // Please report all bugs and problems to "fltk-bugs@fltk.org".
+
+ #include <config.h>
++#include <cstring>
+ #include <fltk/Image.h>
+ #include <fltk/Widget.h>
+ #include <fltk/events.h>
+--- fltk-2.0.x-r6671.orig/src/setcolor.cxx 2009-04-10 16:07:19.000000000 +0200
++++ fltk-2.0.x-r6671/src/setcolor.cxx 2009-04-10 16:08:27.000000000 +0200
+@@ -24,6 +24,7 @@
+ #include <fltk/Color.h>
+ #include <fltk/draw.h>
+ #include <config.h>
++#include <cstring>
+ #if defined(_WIN32) && USE_STOCK_BRUSH && _WIN32_WINNT<0x0500
+ # undef _WIN32_WINNT
+ # define _WIN32_WINNT 0x0500
diff --git a/x11-libs/fltk/fltk-2.0_pre6525.ebuild b/x11-libs/fltk/fltk-2.0_pre6671.ebuild
index 54f990903a4c..ee30abdfc7f2 100644
--- a/x11-libs/fltk/fltk-2.0_pre6525.ebuild
+++ b/x11-libs/fltk/fltk-2.0_pre6671.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/fltk/fltk-2.0_pre6525.ebuild,v 1.8 2009/02/24 12:51:27 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/fltk/fltk-2.0_pre6671.ebuild,v 1.1 2009/04/10 15:09:02 yngwin Exp $
-EAPI="1"
+EAPI="2"
inherit multilib autotools flag-o-matic
MY_P=${P/_pre/.x-r}
@@ -10,7 +10,7 @@ DESCRIPTION="C++ user interface toolkit for X and OpenGL"
HOMEPAGE="http://www.fltk.org/"
SRC_URI="mirror://easysw/fltk/snapshots/${MY_P}.tar.bz2"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ppc64 ~sparc ~x86"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
LICENSE="FLTK LGPL-2"
SLOT="2"
IUSE="cairo debug doc +jpeg +png opengl +xft xinerama zlib"
@@ -34,16 +34,15 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${MY_P}"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
epatch "${FILESDIR}"/fltk2-config.patch
+ epatch "${FILESDIR}"/fltk2-gcc43.patch
sed -i "/STRIP/d" fluid/Makefile # don't pre-strip, bug 246694
use opengl || epatch "${FILESDIR}"/fltk2-nogl.patch
eautoreconf
}
-src_compile() {
+src_configure() {
append-flags -fno-strict-aliasing
CPPFLAGS="${CPPFLAGS} -DFLTK_DOCDIR=\"/usr/share/doc/${PF}\"" \
@@ -56,7 +55,9 @@ src_compile() {
$(use_enable png) \
$(use_enable xinerama) \
$(use_enable zlib)
+}
+src_compile() {
emake || die "make failed"
if use doc; then