summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatti Bickel <mabi@gentoo.org>2008-02-20 16:40:19 +0000
committerMatti Bickel <mabi@gentoo.org>2008-02-20 16:40:19 +0000
commite01f61ba7a308563213d7a63e4018fe6427c4b61 (patch)
tree2a90181e12a19fa2f4aa01ed6b36b416fa3d105d /x11-libs/fox/fox-1.6.27.ebuild
parentRe-add bindnow LDFLAGS (#210837). (diff)
downloadhistorical-e01f61ba7a308563213d7a63e4018fe6427c4b61.tar.gz
historical-e01f61ba7a308563213d7a63e4018fe6427c4b61.tar.bz2
historical-e01f61ba7a308563213d7a63e4018fe6427c4b61.zip
resurrect -1.6.27 until bug 210543 is solved
Package-Manager: portage-2.1.4.4 RepoMan-Options: --force
Diffstat (limited to 'x11-libs/fox/fox-1.6.27.ebuild')
-rw-r--r--x11-libs/fox/fox-1.6.27.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/x11-libs/fox/fox-1.6.27.ebuild b/x11-libs/fox/fox-1.6.27.ebuild
new file mode 100644
index 000000000000..231d08725c7a
--- /dev/null
+++ b/x11-libs/fox/fox-1.6.27.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/fox/fox-1.6.27.ebuild,v 1.9 2008/02/20 16:40:19 mabi Exp $
+
+inherit fox
+
+LICENSE="LGPL-2.1"
+SLOT="1.6"
+KEYWORDS="alpha amd64 hppa ia64 ~ppc ppc64 sparc x86"
+IUSE="bzip2 cups jpeg opengl png threads tiff truetype zlib"
+
+RDEPEND="x11-libs/libXrandr
+ x11-libs/libXcursor
+ x11-libs/fox-wrapper
+ bzip2? ( >=app-arch/bzip2-1.0.2 )
+ cups? ( net-print/cups )
+ jpeg? ( >=media-libs/jpeg-6b )
+ opengl? ( virtual/opengl virtual/glu )
+ png? ( >=media-libs/libpng-1.2.5 )
+ tiff? ( >=media-libs/tiff-3.5.7 )
+ truetype? ( =media-libs/freetype-2*
+ virtual/xft )
+ zlib? ( >=sys-libs/zlib-1.1.4 )"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto
+ x11-libs/libXt"
+
+FOXCONF="$(use_enable bzip2 bz2lib) \
+ $(use_enable cups) \
+ $(use_enable jpeg) \
+ $(use_with opengl) \
+ $(use_enable png) \
+ $(use_enable threads threadsafe) \
+ $(use_enable tiff) \
+ $(use_with truetype xft) \
+ $(use_enable zlib)"