summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGabriele Giorgetti <stroke@gentoo.org>2002-07-29 20:35:08 +0000
committerGabriele Giorgetti <stroke@gentoo.org>2002-07-29 20:35:08 +0000
commit25b6d89dee00ec30980675a540fc39e3ba5faa81 (patch)
tree81bf116e6ed821ee279e0d83501927c0267bef27 /x11-libs/fox
parentbug #5684 (diff)
downloadhistorical-25b6d89dee00ec30980675a540fc39e3ba5faa81.tar.gz
historical-25b6d89dee00ec30980675a540fc39e3ba5faa81.tar.bz2
historical-25b6d89dee00ec30980675a540fc39e3ba5faa81.zip
New Package C++ based Toolkit for developing Graphical User Interfaces. Closes bug #3969
Diffstat (limited to 'x11-libs/fox')
-rw-r--r--x11-libs/fox/ChangeLog10
-rw-r--r--x11-libs/fox/files/digest-fox-1.0.171
-rw-r--r--x11-libs/fox/fox-1.0.17.ebuild50
3 files changed, 61 insertions, 0 deletions
diff --git a/x11-libs/fox/ChangeLog b/x11-libs/fox/ChangeLog
new file mode 100644
index 000000000000..79103b8f6fa8
--- /dev/null
+++ b/x11-libs/fox/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for x11-libs/fox
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/fox/ChangeLog,v 1.1 2002/07/29 20:35:08 stroke Exp $
+
+*fox-1.0.17.ebuild (29 Jul 2002)
+
+ 29 Jul 2002; Gabriele Giorgetti <stroke@gentoo.org> fox-1.0.17.ebuild:
+
+ Initial cvs import.
+ Ebuild submitted by Brian Olsen <bnolsen@attbi.com> (bug #3969)
diff --git a/x11-libs/fox/files/digest-fox-1.0.17 b/x11-libs/fox/files/digest-fox-1.0.17
new file mode 100644
index 000000000000..321ab1859213
--- /dev/null
+++ b/x11-libs/fox/files/digest-fox-1.0.17
@@ -0,0 +1 @@
+MD5 d22d1b6ac76b1bcce977fb708b6edadd fox-1.0.17.tar.gz 2108125
diff --git a/x11-libs/fox/fox-1.0.17.ebuild b/x11-libs/fox/fox-1.0.17.ebuild
new file mode 100644
index 000000000000..24d525c4f736
--- /dev/null
+++ b/x11-libs/fox/fox-1.0.17.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/fox/fox-1.0.17.ebuild,v 1.1 2002/07/29 20:35:08 stroke Exp $
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="C++ based Toolkit for developing Graphical User Interfaces easily a nd effectively"
+
+SRC_URI="http://www.fox-toolkit.org/ftp/${P}.tar.gz"
+
+HOMEPAGE="http://www.fox-toolkit.org"
+
+SLOT="0"
+KEYWORDS="x86"
+LICENSE="GPL-2"
+
+DEPEND="virtual/glibc
+ virtual/x11
+ opengl? ( virtual/opengl )"
+
+RDEPEND="${DEPEND}"
+
+src_compile() {
+
+ local myconf
+
+ use opengl || myconf="$myconf --with-opengl=no" #default enabled
+ use cups && myconf="$myconf --enable-cups" #default disabled
+
+ ./configure \
+ --prefix=/usr \
+ --mandir='${prefix}'/share/man \
+ --host=${CHOST} \
+ ${myconf} || die "Configuration Failed"
+
+ emake || die "Parallel Make Failed"
+}
+
+src_install () {
+
+ make prefix=${D}/usr/ \
+ install || die "Installation Failed"
+
+ dodoc README INSTALL LICENSE ADDITIONS AUTHORS TRACING
+
+ dodir /usr/share/doc/${PF}/html
+ mv ${D}/usr/fox/html/* ${D}/usr/share/doc/${PF}/html/
+ rmdir ${D}/usr/fox/html
+ rmdir ${D}/usr/fox
+}