summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorD.M.D. Ljungmark <spider@gentoo.org>2002-05-28 02:08:11 +0000
committerD.M.D. Ljungmark <spider@gentoo.org>2002-05-28 02:08:11 +0000
commitc2c9e7f6775a3e5c65b1e406b4357ecac880980f (patch)
tree75261386f373ee702f55f5555a1b1723d194dd06 /x11-libs/gtk+
parentmasked links-2.0_pre4 (diff)
downloadhistorical-c2c9e7f6775a3e5c65b1e406b4357ecac880980f.tar.gz
historical-c2c9e7f6775a3e5c65b1e406b4357ecac880980f.tar.bz2
historical-c2c9e7f6775a3e5c65b1e406b4357ecac880980f.zip
png bug fix
Diffstat (limited to 'x11-libs/gtk+')
-rw-r--r--x11-libs/gtk+/ChangeLog6
-rw-r--r--x11-libs/gtk+/files/digest-gtk+-2.0.2-r61
-rw-r--r--x11-libs/gtk+/gtk+-2.0.2-r6.ebuild76
3 files changed, 82 insertions, 1 deletions
diff --git a/x11-libs/gtk+/ChangeLog b/x11-libs/gtk+/ChangeLog
index 22556e25b6bd..83d0a3234d41 100644
--- a/x11-libs/gtk+/ChangeLog
+++ b/x11-libs/gtk+/ChangeLog
@@ -1,6 +1,6 @@
# ChangeLog for x11-libs/gtk+
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/ChangeLog,v 1.13 2002/05/28 00:00:48 blocke Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/ChangeLog,v 1.14 2002/05/28 02:08:11 spider Exp $
*gtk+-1.2.10-r8 (27 May 2002)
@@ -8,6 +8,10 @@
Ximian patch set and redhat/mdk patch merged
+*gtk+-2.0.2-r6 (27 May 2002)
+ 27 May 2002; Spider <spider@gentoo.org> gtk+-2.0.2-r6.ebuild:
+ fix for the use png bug, not libtoolized
+
*gtk+-2.0.2-r5 (23 May 2002)
23 May 2002; Spider <spider@gentoo.org> gtk+-2.0.2-r5.ebuild:
seems people who installed with the libtoolized version of gtk+ fails
diff --git a/x11-libs/gtk+/files/digest-gtk+-2.0.2-r6 b/x11-libs/gtk+/files/digest-gtk+-2.0.2-r6
new file mode 100644
index 000000000000..665e7da38da8
--- /dev/null
+++ b/x11-libs/gtk+/files/digest-gtk+-2.0.2-r6
@@ -0,0 +1 @@
+MD5 b8df4c513323b9efc9a157703f25a07f gtk+-2.0.2.tar.bz2 5683089
diff --git a/x11-libs/gtk+/gtk+-2.0.2-r6.ebuild b/x11-libs/gtk+/gtk+-2.0.2-r6.ebuild
new file mode 100644
index 000000000000..a331e2c99b88
--- /dev/null
+++ b/x11-libs/gtk+/gtk+-2.0.2-r6.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Spider <spider@gentoo.org>
+# Maintainer: Spider <spider@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/gtk+-2.0.2-r6.ebuild,v 1.1 2002/05/28 02:08:11 spider Exp $
+
+SLOT="2"
+
+# Do _NOT_ strip symbols in the build! Need both lines for Portage 1.8.9+
+DEBUG="yes"
+RESTRICT="nostrip"
+# force debug information
+CFLAGS="${CFLAGS} -g"
+CXXFLAGS="${CXXFLAGS} -g"
+
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Gimp ToolKit + "
+SRC_URI="ftp://ftp.gtk.org/pub/gtk/v2.0/${P}.tar.bz2"
+HOMEPAGE="http://www.gtk.org/"
+LICENSE="LGPL-2.1"
+
+RDEPEND="virtual/x11
+ >=dev-libs/glib-2.0.1
+ >=dev-libs/atk-1.0.1
+ >=x11-libs/pango-1.0.1
+ >=media-libs/libpng-1.2.1
+ jpeg? ( >=media-libs/jpeg-6b-r2 )
+ tiff? ( >=media-libs/tiff-3.5.7 )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.12.0
+ doc? ( >=dev-util/gtk-doc-0.9 )"
+
+src_compile() {
+
+ # seems things broke here.. odd readding to test
+# commented out to commit mainline gtk+
+# libtoolize --copy --force
+ local myconf
+ use doc && myconf="${myconf} --enable-gtk-doc" || myconf="${myconf} --disable-gtk-doc"
+# reported to break without png
+# use png || myconf="${myconf} --without-libpng"
+ use jpeg || myconf="${myconf} --without-libjpeg"
+ use tiff || myconf="${myconf} --without-libtiff"
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --with-gdktarget=x11 \
+ ${myconf} \
+ --enable-debug || die
+# enable debug since glib fails if we disable it
+
+# gtk+ isn't multithread friendly due to some obscure code generation bug
+ make || die
+}
+
+src_install() {
+ dodir /etc/gtk-2.0
+ make DESTDIR=${D} \
+ prefix=/usr \
+ sysconfdir=/etc \
+ infodir=/usr/share/info \
+ mandir=/usr/share/man \
+ install || die
+ dodoc AUTHORS COPYING ChangeLog* HACKING* INSTALL NEWS* README* TODO
+}
+
+
+pkg_postinst() {
+ gtk-query-immodules-2.0 > /etc/gtk-2.0/gtk.immodules
+}
+