summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2010-09-30 10:32:22 +0000
committerFabian Groffen <grobian@gentoo.org>2010-09-30 10:32:22 +0000
commit0840e7cb9c0227e7cd9f84f78b00f78664747ba1 (patch)
tree85a9bb916b1a586340f417719b3cf2dfc7d68ae7 /x11-libs/ige-mac-integration/ige-mac-integration-9999.ebuild
parentMake the ebuild respect LDFLAGS (bug #337408). (diff)
downloadhistorical-0840e7cb9c0227e7cd9f84f78b00f78664747ba1.tar.gz
historical-0840e7cb9c0227e7cd9f84f78b00f78664747ba1.tar.bz2
historical-0840e7cb9c0227e7cd9f84f78b00f78664747ba1.zip
Import x11-libs/ige-mac-integration, a package to do Mac OS X specific stuff with GTK+. Live ebuild, thanks to Heiko Przybyl.
Package-Manager: portage-2.2.01.16706-prefix/cvs/Darwin powerpc
Diffstat (limited to 'x11-libs/ige-mac-integration/ige-mac-integration-9999.ebuild')
-rw-r--r--x11-libs/ige-mac-integration/ige-mac-integration-9999.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/x11-libs/ige-mac-integration/ige-mac-integration-9999.ebuild b/x11-libs/ige-mac-integration/ige-mac-integration-9999.ebuild
new file mode 100644
index 000000000000..7caed8b31ebc
--- /dev/null
+++ b/x11-libs/ige-mac-integration/ige-mac-integration-9999.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/ige-mac-integration/ige-mac-integration-9999.ebuild,v 1.1 2010/09/30 10:32:22 grobian Exp $
+
+EAPI="3"
+
+inherit autotools base git python
+
+EGIT_REPO_URI="git://github.com/rhult/ige-mac-integration.git"
+SRC_URI=""
+
+DESCRIPTION="GTK+ bindings for Mac OS X specific tasks"
+LICENSE="LGPL-2"
+HOMEPAGE="http://live.gnome.org/GTK+/OSX/Integration"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+RESTRICT="stricter"
+RDEPEND="x11-libs/gtk+
+ dev-python/pygtk"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ git_src_prepare
+
+ # fix the lookup of the codegen tools
+ sed -e "s|\$(datadir)/pygtk/2.0|${EPREFIX}/$(python_get_sitedir)/gtk-2.0|g" \
+ -i bindings/python/Makefile.am
+
+ eautoreconf
+}
+
+src_configure() {
+ econf --with-compile-warnings=no
+}