summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2010-10-28 11:28:08 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2010-10-28 11:28:08 +0000
commit47322cba35a924588e8e9de47e432ae5c6f18f05 (patch)
tree45bbfdadd56ee5ac50c7d2e788b54126f2ea2d47 /x11-libs/libSM/libSM-1.2.0.ebuild
parentVersion bump. (diff)
downloadhistorical-47322cba35a924588e8e9de47e432ae5c6f18f05.tar.gz
historical-47322cba35a924588e8e9de47e432ae5c6f18f05.tar.bz2
historical-47322cba35a924588e8e9de47e432ae5c6f18f05.zip
Version bump.
Package-Manager: portage-2.2_rc98/cvs/Linux x86_64
Diffstat (limited to 'x11-libs/libSM/libSM-1.2.0.ebuild')
-rw-r--r--x11-libs/libSM/libSM-1.2.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/x11-libs/libSM/libSM-1.2.0.ebuild b/x11-libs/libSM/libSM-1.2.0.ebuild
new file mode 100644
index 000000000000..051491227030
--- /dev/null
+++ b/x11-libs/libSM/libSM-1.2.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libSM/libSM-1.2.0.ebuild,v 1.1 2010/10/28 11:28:08 scarabeus Exp $
+
+EAPI=3
+inherit xorg-2
+
+DESCRIPTION="X.Org SM library"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc ipv6 +uuid"
+
+RDEPEND="x11-libs/libICE
+ x11-libs/xtrans
+ !elibc_FreeBSD? (
+ uuid? ( >=sys-apps/util-linux-2.16 )
+ )"
+DEPEND="${RDEPEND}
+ x11-proto/xproto
+ doc? ( app-text/xmlto )"
+
+pkg_setup() {
+ CONFIGURE_OPTIONS="$(use_enable ipv6)
+ $(use_enable doc docs)
+ $(use_with doc xmlto)
+ $(use_with uuid libuuid)
+ --without-fop"
+ # do not use uuid even if available in libc (like on FreeBSD)
+ use uuid || export ac_cv_func_uuid_create=no
+}