summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIngmar Vanhassel <ingmar@gentoo.org>2008-04-10 13:39:48 +0000
committerIngmar Vanhassel <ingmar@gentoo.org>2008-04-10 13:39:48 +0000
commitaf46d075a2f3006cfc4da920ead7f54ee00dc9a7 (patch)
treeada6ff78491f50ad3a4f0dae6ebf604b9c9f01e8 /x11-libs/qt-core
parentVersion bump qt-assistant to 4.4.0_rc1. Thanks to Bo Andresen and Bernd Stein... (diff)
downloadhistorical-af46d075a2f3006cfc4da920ead7f54ee00dc9a7.tar.gz
historical-af46d075a2f3006cfc4da920ead7f54ee00dc9a7.tar.bz2
historical-af46d075a2f3006cfc4da920ead7f54ee00dc9a7.zip
Version bump qt-core to 4.4.0_rc1. Thanks to Bo Andresen and Bernd Steinhauser.
Package-Manager: portage-2.1.5_rc2
Diffstat (limited to 'x11-libs/qt-core')
-rw-r--r--x11-libs/qt-core/ChangeLog7
-rw-r--r--x11-libs/qt-core/qt-core-4.4.0_rc1.ebuild (renamed from x11-libs/qt-core/qt-core-4.4.0_beta1.ebuild)49
2 files changed, 45 insertions, 11 deletions
diff --git a/x11-libs/qt-core/ChangeLog b/x11-libs/qt-core/ChangeLog
index 77af17131f00..30def2a99036 100644
--- a/x11-libs/qt-core/ChangeLog
+++ b/x11-libs/qt-core/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/qt-core
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-core/ChangeLog,v 1.3 2008/03/05 23:23:52 ingmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-core/ChangeLog,v 1.4 2008/04/10 13:39:48 ingmar Exp $
+
+ 10 Apr 2008; Ingmar Vanhassel <ingmar@gentoo.org>
+ -qt-core-4.4.0_beta1.ebuild, +qt-core-4.4.0_rc1.ebuild:
+ Version bump qt-core to 4.4.0_rc1. Thanks to Bo Andresen and Bernd
+ Steinhauser.
05 Mar 2008; Ingmar Vanhassel <ingmar@gentoo.org>
-qt-core-4.4.0_rc1.ebuild:
diff --git a/x11-libs/qt-core/qt-core-4.4.0_beta1.ebuild b/x11-libs/qt-core/qt-core-4.4.0_rc1.ebuild
index 7b3c19941dda..071aed6dbdd1 100644
--- a/x11-libs/qt-core/qt-core-4.4.0_beta1.ebuild
+++ b/x11-libs/qt-core/qt-core-4.4.0_rc1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-core/qt-core-4.4.0_beta1.ebuild,v 1.1 2008/03/05 23:07:18 ingmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-core/qt-core-4.4.0_rc1.ebuild,v 1.13 2008/04/10 13:39:48 ingmar Exp $
EAPI="1"
inherit qt4-build
@@ -21,13 +21,29 @@ DEPEND="${RDEPEND}
dev-util/pkgconfig"
QT4_TARGET_DIRECTORIES="
-src/tools/moc
-src/tools/rcc
-src/tools/uic
-src/corelib
-src/xml
-src/network
-src/plugins/codecs"
+src/tools/moc/
+src/tools/rcc/
+src/tools/uic/
+src/corelib/
+src/xml/
+src/network/
+src/plugins/codecs/"
+QT4_EXTRACT_DIRECTORIES="
+include/Qt/
+include/QtCore/
+include/QtNetwork/
+include/QtScript/
+include/QtXml/
+src/plugins/plugins.pro
+src/plugins/qpluginbase.pri
+src/src.pro
+src/3rdparty/des/
+src/3rdparty/harfbuzz/
+src/3rdparty/md4/
+src/3rdparty/md5/
+src/3rdparty/sha1/
+src/script/
+translations/"
pkg_setup() {
qt4-build_pkg_setup
@@ -74,6 +90,14 @@ pkg_setup() {
fi
}
+src_unpack() {
+ use doc && QT4_EXTRACT_DIRECTORIES="${QT4_EXTRACT_DIRECTORIES}
+ doc/
+ tools/qdoc3/"
+
+ qt4-build_src_unpack
+}
+
src_compile() {
unset QMAKESPEC
local myconf
@@ -85,9 +109,14 @@ src_compile() {
myconf="${myconf} -no-xkb -no-tablet -no-fontconfig -no-xrender -no-xrandr
-no-xfixes -no-xcursor -no-xinerama -no-xshape -no-sm -no-opengl
- -no-nas-sound -no-qdbus -iconv -no-cups -no-nis -no-gif -no-libpng
+ -no-nas-sound -no-dbus -iconv -no-cups -no-nis -no-gif -no-libpng
-no-libmng -no-libjpeg -system-zlib -no-webkit -no-phonon -no-xmlpatterns
- -no-freetype -no-libtiff -no-accessibility -no-fontconfig -no-opengl"
+ -no-freetype -no-libtiff -no-accessibility -no-fontconfig -no-opengl
+ -no-svg"
+
+ if ! use doc; then
+ myconf="${myconf} -nomake docs"
+ fi
qt4-build_src_compile
}