summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIngmar Vanhassel <ingmar@gentoo.org>2008-05-25 14:22:26 +0000
committerIngmar Vanhassel <ingmar@gentoo.org>2008-05-25 14:22:26 +0000
commit453a85c52227861f77efc18be3ec0108e086f4fa (patch)
tree675b03239b412f5f0ba39fb45d6b108114f1b65f /x11-libs/qt-demo/qt-demo-4.4.0.ebuild
parentAdd x11-libs/qt-demo to the Qt-4.4.0 mask. (diff)
downloadhistorical-453a85c52227861f77efc18be3ec0108e086f4fa.tar.gz
historical-453a85c52227861f77efc18be3ec0108e086f4fa.tar.bz2
historical-453a85c52227861f77efc18be3ec0108e086f4fa.zip
Import x11-libs/qt-demo, thanks to Bernd Steinhauser <berniyh@exherbo.org> for the ebuild.
Package-Manager: portage-2.1.5.2
Diffstat (limited to 'x11-libs/qt-demo/qt-demo-4.4.0.ebuild')
-rw-r--r--x11-libs/qt-demo/qt-demo-4.4.0.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/x11-libs/qt-demo/qt-demo-4.4.0.ebuild b/x11-libs/qt-demo/qt-demo-4.4.0.ebuild
new file mode 100644
index 000000000000..b93aa303e5bc
--- /dev/null
+++ b/x11-libs/qt-demo/qt-demo-4.4.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-demo/qt-demo-4.4.0.ebuild,v 1.1 2008/05/25 14:22:26 ingmar Exp $
+
+EAPI="1"
+inherit qt4-build
+
+DESCRIPTION="Demonstration module of the Qt toolkit."
+HOMEPAGE="http://www.trolltech.com/"
+
+LICENSE="|| ( QPL-1.0 GPL-3 GPL-2 )"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ ~x11-libs/qt-assistant-${PV}:${SLOT}
+ ~x11-libs/qt-core-${PV}:${SLOT}
+ ~x11-libs/qt-dbus-${PV}:${SLOT}
+ ~x11-libs/qt-gui-${PV}:${SLOT}
+ ~x11-libs/qt-opengl-${PV}:${SLOT}
+ ~x11-libs/qt-phonon-${PV}:${SLOT}
+ ~x11-libs/qt-qt3support-${PV}:${SLOT}
+ ~x11-libs/qt-script-${PV}:${SLOT}
+ ~x11-libs/qt-sql-${PV}:${SLOT}
+ ~x11-libs/qt-svg-${PV}:${SLOT}
+ ~x11-libs/qt-test-${PV}:${SLOT}
+ ~x11-libs/qt-webkit-${PV}:${SLOT}
+ ~x11-libs/qt-xmlpatterns-${PV}:${SLOT}
+ "
+RDEPEND="${DEPEND}"
+
+QT4_TARGET_DIRECTORIES="demos
+ examples"
+QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
+ doc/src/images"
+
+src_compile() {
+ # Doesn't find qt-gui and fails linking
+ sed -e '/QT_BUILD_TREE/ a LIBS+=-L/usr/lib64/qt4\n' \
+ -i "${S}"/examples/tools/plugandpaint/plugandpaint.pro \
+ || die "Fixing plugandpaint example failed."
+
+ qt4-build_src_compile
+}
+
+src_install() {
+ insinto ${QTDOCDIR}/src
+ doins -r "${S}"/doc/src/images || die "Installing images failed."
+
+ qt4-build_src_install
+}