summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcus D. Hanwell <cryos@gentoo.org>2005-10-14 02:01:32 +0000
committerMarcus D. Hanwell <cryos@gentoo.org>2005-10-14 02:01:32 +0000
commit8e950d5c0fc318f28933288d1abfdee1c8b89b31 (patch)
treee6df79e0a88f20ddbf2b96c5e78b7ba3db65ad88 /x11-libs/qwtplot3d
parentMark 2.4.2 stable on alpha (diff)
downloadhistorical-8e950d5c0fc318f28933288d1abfdee1c8b89b31.tar.gz
historical-8e950d5c0fc318f28933288d1abfdee1c8b89b31.tar.bz2
historical-8e950d5c0fc318f28933288d1abfdee1c8b89b31.zip
Initial import, ebuild submitted by Martin Corley <Martin.Corley@ed.ac.uk>, closes bug 83294.
Package-Manager: portage-2.0.53_rc5
Diffstat (limited to 'x11-libs/qwtplot3d')
-rw-r--r--x11-libs/qwtplot3d/ChangeLog11
-rw-r--r--x11-libs/qwtplot3d/Manifest14
-rw-r--r--x11-libs/qwtplot3d/files/digest-qwtplot3d-0.2.61
-rw-r--r--x11-libs/qwtplot3d/metadata.xml12
-rw-r--r--x11-libs/qwtplot3d/qwtplot3d-0.2.6.ebuild50
5 files changed, 88 insertions, 0 deletions
diff --git a/x11-libs/qwtplot3d/ChangeLog b/x11-libs/qwtplot3d/ChangeLog
new file mode 100644
index 000000000000..09f1b097dafd
--- /dev/null
+++ b/x11-libs/qwtplot3d/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for x11-libs/qwtplot3d
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qwtplot3d/ChangeLog,v 1.1 2005/10/14 02:01:32 cryos Exp $
+
+*qwtplot3d-0.2.6 (14 Oct 2005)
+
+ 14 Oct 2005; Marcus D. Hanwell <cryos@gentoo.org> +metadata.xml,
+ +qwtplot3d-0.2.6.ebuild:
+ Initial import, ebuild submitted by Martin Corley <Martin.Corley@ed.ac.uk>,
+ closes bug 83294.
+
diff --git a/x11-libs/qwtplot3d/Manifest b/x11-libs/qwtplot3d/Manifest
new file mode 100644
index 000000000000..489ab1315d2c
--- /dev/null
+++ b/x11-libs/qwtplot3d/Manifest
@@ -0,0 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 146323f06bd61a8d4f4f1efd67547477 ChangeLog 433
+MD5 cf9aaa8e69c2706b69104c537365485c files/digest-qwtplot3d-0.2.6 64
+MD5 215d34fcda8923ada4f99f2fbcd3a983 metadata.xml 401
+MD5 e0fefa25ffb8ff4f77f40bbd7679b204 qwtplot3d-0.2.6.ebuild 1390
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.1 (GNU/Linux)
+
+iD8DBQFDTxGKntT9W3vfTuoRAvaFAJ99OHXTKRWJcVjnjOPClAAiQxKcEwCcDRBC
+tjefZBT4yM+VayQh5qShpNM=
+=o1bs
+-----END PGP SIGNATURE-----
diff --git a/x11-libs/qwtplot3d/files/digest-qwtplot3d-0.2.6 b/x11-libs/qwtplot3d/files/digest-qwtplot3d-0.2.6
new file mode 100644
index 000000000000..3fd7d3d93732
--- /dev/null
+++ b/x11-libs/qwtplot3d/files/digest-qwtplot3d-0.2.6
@@ -0,0 +1 @@
+MD5 7ef960d7874f78162d6c9d241de2843e qwtplot3d-0.2.6.tgz 148834
diff --git a/x11-libs/qwtplot3d/metadata.xml b/x11-libs/qwtplot3d/metadata.xml
new file mode 100644
index 000000000000..5f54308dd55b
--- /dev/null
+++ b/x11-libs/qwtplot3d/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <maintainer>
+ <email>cryos@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ QwtPlot3D isa feature-rich Qt/OpenGL-based C++ programming library,
+ providing essentially a bunch of 3D-widgets for programmers.
+ </longdescription>
+</pkgmetadata>
diff --git a/x11-libs/qwtplot3d/qwtplot3d-0.2.6.ebuild b/x11-libs/qwtplot3d/qwtplot3d-0.2.6.ebuild
new file mode 100644
index 000000000000..03118b5267cb
--- /dev/null
+++ b/x11-libs/qwtplot3d/qwtplot3d-0.2.6.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qwtplot3d/qwtplot3d-0.2.6.ebuild,v 1.1 2005/10/14 02:01:32 cryos Exp $
+
+inherit multilib
+
+MY_P=${P/_/-}
+S=${WORKDIR}/${PN}
+
+DESCRIPTION="opengl and qt-based 3D widget library for C++"
+HOMEPAGE="http://qwtplot3d.sourceforge.net/"
+SRC_URI="mirror://sourceforge/qwtplot3d/${MY_P}.tgz"
+
+LICENSE="as-is"
+SLOT="0"
+IUSE="doc"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="=x11-libs/qt-3*
+ >=sys-apps/sed-4"
+
+src_unpack () {
+ unpack ${A}
+ cd ${S}
+ find . -type f -name "*.pro" | while read file; do
+ sed -e 's/.*no-exceptions.*//g' -i ${file}
+ echo >> ${file} "QMAKE_CFLAGS_RELEASE += ${CFLAGS}"
+ echo >> ${file} "QMAKE_CXXFLAGS_RELEASE += ${CXXFLAGS}"
+ done
+ find examples -type f -name "*.pro" | while read file; do
+ echo >> ${file} "INCLUDEPATH += /usr/include/qwtplot3d"
+ done
+}
+
+src_compile () {
+ addwrite ${QTDIR}/etc/settings
+ qmake qwtplot3d.pro
+ emake || die
+}
+
+src_install () {
+ dolib lib/libqwtplot3d.so.${PV}
+ dosym libqwtplot3d.so.${PV} /usr/$(get_libdir)/libqwtplot3d.so
+ dosym libqwtplot3d.so.${PV} /usr/$(get_libdir)/libqwtplot3d.so.${PV/.*/}
+ chmod -R 644 examples
+ mkdir -p ${D}/usr/include/qwtplot3d/
+ install include/* ${D}/usr/include/qwtplot3d/
+ use doc && (dodir /usr/share/doc/${PF}
+ cp -pPR examples ${D}/usr/share/doc/${PF}/)
+}