summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-02-27 13:47:23 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-02-27 13:47:23 +0000
commitf0d03bf76517937670d279a528a30b0eb805c8d5 (patch)
tree9b39ac2fd40137df7d647dc380296ef085aad755 /x11-libs/vdpau-video/vdpau-video-0.7.3.ebuild
parentVersion bump for mono-2.10 (diff)
downloadhistorical-f0d03bf76517937670d279a528a30b0eb805c8d5.tar.gz
historical-f0d03bf76517937670d279a528a30b0eb805c8d5.tar.bz2
historical-f0d03bf76517937670d279a528a30b0eb805c8d5.zip
version bump
Package-Manager: portage-2.2.0_alpha25/cvs/Linux x86_64
Diffstat (limited to 'x11-libs/vdpau-video/vdpau-video-0.7.3.ebuild')
-rw-r--r--x11-libs/vdpau-video/vdpau-video-0.7.3.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/x11-libs/vdpau-video/vdpau-video-0.7.3.ebuild b/x11-libs/vdpau-video/vdpau-video-0.7.3.ebuild
new file mode 100644
index 000000000000..845281eed53b
--- /dev/null
+++ b/x11-libs/vdpau-video/vdpau-video-0.7.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/vdpau-video/vdpau-video-0.7.3.ebuild,v 1.1 2011/02/27 13:47:23 aballier Exp $
+
+EAPI="2"
+inherit autotools
+
+MY_P=${P/_/.}
+DESCRIPTION="VDPAU Backend for Video Acceleration (VA) API"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/vaapi"
+SRC_URI="http://www.splitted-desktop.com/~gbeauchesne/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug opengl"
+
+RDEPEND="x11-libs/libva[opengl?]
+ opengl? ( virtual/opengl )
+ x11-libs/libvdpau"
+
+DEPEND="${DEPEND}
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable opengl glx)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc NEWS README AUTHORS
+ find "${D}" -name '*.la' -delete
+}