summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Heim <phreak@gentoo.org>2007-02-18 16:24:14 +0000
committerChristian Heim <phreak@gentoo.org>2007-02-18 16:24:14 +0000
commit58abe754773532f645c8673cb0847239933ae22c (patch)
treec3c31edcad234f1f5c95536bd022e3ba9572740e /x11-libs/xforms/xforms-1.0.90-r1.ebuild
parentVersion bump (diff)
downloadhistorical-58abe754773532f645c8673cb0847239933ae22c.tar.gz
historical-58abe754773532f645c8673cb0847239933ae22c.tar.bz2
historical-58abe754773532f645c8673cb0847239933ae22c.zip
Fixing breakage w/ fdesign/Makefile.am and lib/Makefile.am (eleminating the remaining commented out lines, that make automake fail badly) thanks to Fabian Groffen and Bo Orsted Andresen <bo.andresen at zlin.dk> in #161857.
Package-Manager: portage-2.1.2-r9
Diffstat (limited to 'x11-libs/xforms/xforms-1.0.90-r1.ebuild')
-rw-r--r--x11-libs/xforms/xforms-1.0.90-r1.ebuild16
1 files changed, 10 insertions, 6 deletions
diff --git a/x11-libs/xforms/xforms-1.0.90-r1.ebuild b/x11-libs/xforms/xforms-1.0.90-r1.ebuild
index 14f2c015e455..cca7b7d77f44 100644
--- a/x11-libs/xforms/xforms-1.0.90-r1.ebuild
+++ b/x11-libs/xforms/xforms-1.0.90-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/xforms/xforms-1.0.90-r1.ebuild,v 1.8 2006/11/22 17:44:14 masterdriverz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/xforms/xforms-1.0.90-r1.ebuild,v 1.9 2007/02/18 16:24:14 phreak Exp $
inherit autotools
@@ -28,14 +28,18 @@ DEPEND=" || (
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${P}-as-needed.patch
- eautoreconf || die 'eautoreconf failed'
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-as-needed.patch
+ epatch "${FILESDIR}"/${P}-Makefile.am.patch
+
+ eautoreconf
}
src_compile () {
local myopts
- if ! use opengl; then myopts="--disable-gl"; fi
+ use opengl || myopts="--disable-gl"
+
econf ${myopts} || die "econf failed"
emake || die "emake failed"
}