summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-08-05 10:02:51 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-08-05 10:02:51 +0000
commitca2ca9b65bbc3ab8ee486afb137316bc97db3903 (patch)
tree42d6b7ee1bcc94d68f654ae21c12dcb794558d69 /x11-libs/xforms
parentperl testing on ppc; added positive test results (diff)
downloadhistorical-ca2ca9b65bbc3ab8ee486afb137316bc97db3903.tar.gz
historical-ca2ca9b65bbc3ab8ee486afb137316bc97db3903.tar.bz2
historical-ca2ca9b65bbc3ab8ee486afb137316bc97db3903.zip
modernised
Diffstat (limited to 'x11-libs/xforms')
-rw-r--r--x11-libs/xforms/xforms-1.0_rc4.ebuild25
1 files changed, 14 insertions, 11 deletions
diff --git a/x11-libs/xforms/xforms-1.0_rc4.ebuild b/x11-libs/xforms/xforms-1.0_rc4.ebuild
index 2948cab53520..6f2a89531d64 100644
--- a/x11-libs/xforms/xforms-1.0_rc4.ebuild
+++ b/x11-libs/xforms/xforms-1.0_rc4.ebuild
@@ -1,27 +1,30 @@
# Copyright 999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/xforms/xforms-1.0_rc4.ebuild,v 1.3 2002/08/01 11:12:30 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/xforms/xforms-1.0_rc4.ebuild,v 1.4 2002/08/05 10:02:51 seemant Exp $
+MY_P=${P/_rc/RC}
+S=${WORKDIR}/${MY_P}
DESCRIPTION="This is a sample skeleton ebuild file"
HOMEPAGE="http://world.std.com/~xforms"
-SRC_URI="ftp://ncmir.ucsd.edu/pub/xforms/OpenSource/xforms-1.0RC4.tgz"
+SRC_URI="ftp://ncmir.ucsd.edu/pub/xforms/OpenSource/${MY_P}.tgz"
-LICENSE="GPL-2"
SLOT="0"
+LICENSE="GPL-2"
KEYWORDS="x86 ppc"
+
DEPEND="virtual/x11"
+
PROVIDES="virtual/xforms"
-S="${WORKDIR}/xforms-1.0RC4"
src_unpack() {
- unpack $A
- cd $S
-
- # use custom CFLAGS
- cp Imakefile Imakefile.orig
- sed -e "s:CDEBUGFLAGS =:CDEBUGFLAGS = ${CFLAGS} #:" \
- -e "s:CDEBUGFLAGS =:CDEBUGFLAGS = ${CFLAGS} #:" Imakefile.orig > Imakefile
+ unpack $A
+ cd $S
+
+ # use custom CFLAGS
+ cp Imakefile Imakefile.orig
+ sed -e "s:CDEBUGFLAGS =:CDEBUGFLAGS = ${CFLAGS} #:" \
+ -e "s:CDEBUGFLAGS =:CDEBUGFLAGS = ${CFLAGS} #:" Imakefile.orig > Imakefile
}