summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-06-14 10:17:23 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-06-14 10:17:23 +0000
commit8adba62df92100695bb742282276464ed176c47c (patch)
tree47480c006e9ace016039742717f2a3288653c01a /x11-libs
parentsome minor tweaks. (diff)
downloadhistorical-8adba62df92100695bb742282276464ed176c47c.tar.gz
historical-8adba62df92100695bb742282276464ed176c47c.tar.bz2
historical-8adba62df92100695bb742282276464ed176c47c.zip
more fix0rs
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/openmotif/ChangeLog7
-rw-r--r--x11-libs/openmotif/Manifest5
-rw-r--r--x11-libs/openmotif/files/mwm-configdir.patch39
-rw-r--r--x11-libs/openmotif/openmotif-2.2.2-r2.ebuild144
4 files changed, 166 insertions, 29 deletions
diff --git a/x11-libs/openmotif/ChangeLog b/x11-libs/openmotif/ChangeLog
index 9eeb23c0b184..c14828f15e24 100644
--- a/x11-libs/openmotif/ChangeLog
+++ b/x11-libs/openmotif/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/openmotif
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/openmotif/ChangeLog,v 1.15 2003/06/06 20:56:38 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/openmotif/ChangeLog,v 1.16 2003/06/14 10:17:20 seemant Exp $
+
+ 14 Jun 2003; Seemant Kulleen <seemant@gentoo.org> openmotif-2.2.2-r2.ebuild,
+ files/mwm-configdir.patch:
+ ok, this is the fixed version, more true to what bartron originally submitted.
+ sorry for that.
*openmotif-2.2.2-r2 (06 Jun 2003)
diff --git a/x11-libs/openmotif/Manifest b/x11-libs/openmotif/Manifest
index 31d140b023a3..66c9f2a9a729 100644
--- a/x11-libs/openmotif/Manifest
+++ b/x11-libs/openmotif/Manifest
@@ -1,7 +1,8 @@
MD5 bab90541194a08586c684da6f7ca75e7 openmotif-2.1.30-r1.ebuild 930
MD5 81204d17ce9b31bf63e865f933ff635e openmotif-2.2.2-r1.ebuild 1044
-MD5 6d82f521481cc0ed76ab8f637798df3e openmotif-2.2.2-r2.ebuild 1836
-MD5 35a0c3f77bc618ad6fedcf3e76c5e209 ChangeLog 2788
+MD5 43f9765170b937c6efe93243a31191f3 openmotif-2.2.2-r2.ebuild 4744
+MD5 e2be0c856903dcb3424662e67e8f892d ChangeLog 2996
+MD5 216193f922fae0747195fd851696b580 files/mwm-configdir.patch 1549
MD5 009fd49058dd31057e2cbdc0c5cbb6a5 files/digest-openmotif-2.2.2-r1 136
MD5 e0b6cf2385221247e7204f63a199c6c3 files/digest-openmotif-2.2.2-r2 68
MD5 818d2d673fe5ee323f93b5a66fb1baca files/digest-openmotif-2.1.30-r1 79
diff --git a/x11-libs/openmotif/files/mwm-configdir.patch b/x11-libs/openmotif/files/mwm-configdir.patch
new file mode 100644
index 000000000000..c83f34aa9a27
--- /dev/null
+++ b/x11-libs/openmotif/files/mwm-configdir.patch
@@ -0,0 +1,39 @@
+diff -urN openMotif-2.2.2.orig/clients/mwm/WmResParse.c openMotif-2.2.2/clients/mwm/WmResParse.c
+--- openMotif-2.2.2.orig/clients/mwm/WmResParse.c 2002-01-10 21:55:37.000000000 +0100
++++ openMotif-2.2.2/clients/mwm/WmResParse.c 2003-06-04 22:20:22.000000000 +0200
+@@ -2411,7 +2411,7 @@
+ if (MwmBehavior)
+ {
+ strcpy(cfileName, LIBDIR);
+- strncat(cfileName, "/", MAXWMPATH-strlen(cfileName));
++ strncat(cfileName, "/mwm/", MAXWMPATH-strlen(cfileName));
+ strncat(cfileName, LANG, MAXWMPATH-strlen(cfileName));
+ strncat(cfileName, SLASH_MWMRC, MAXWMPATH - strlen(cfileName));
+ }
+@@ -2427,7 +2427,7 @@
+ * Try /$LANG/system.mwmrc within the install tree
+ */
+ strcpy(cfileName, LIBDIR);
+- strncat(cfileName, "/", MAXWMPATH-strlen(cfileName));
++ strncat(cfileName, "/mwm/", MAXWMPATH-strlen(cfileName));
+ strncat(cfileName, LANG, MAXWMPATH-strlen(cfileName));
+ strncat(cfileName, SLASH_MWMRC, MAXWMPATH - strlen(cfileName));
+ #endif /* WSM */
+@@ -2449,7 +2449,7 @@
+ if (MwmBehavior)
+ {
+ strcpy(cfileName, LIBDIR);
+- strncat(cfileName, SLASH_MWMRC, MAXWMPATH - strlen(cfileName));
++ strncat(cfileName, "/mwm" SLASH_MWMRC, MAXWMPATH - strlen(cfileName));
+ #ifdef PANELIST
+ fileP = fopen (cfileName, "r");
+ #else /* PANELIST */
+@@ -2473,7 +2473,7 @@
+ * Try /system.mwmrc within the install tree
+ */
+ strcpy(cfileName, LIBDIR);
+- strncat(cfileName, SLASH_MWMRC, MAXWMPATH - strlen(cfileName));
++ strncat(cfileName, "/mwm" SLASH_MWMRC, MAXWMPATH - strlen(cfileName));
+
+ if (LANG != NULL)
+ {
diff --git a/x11-libs/openmotif/openmotif-2.2.2-r2.ebuild b/x11-libs/openmotif/openmotif-2.2.2-r2.ebuild
index 217dba84a40e..b646a6efa200 100644
--- a/x11-libs/openmotif/openmotif-2.2.2-r2.ebuild
+++ b/x11-libs/openmotif/openmotif-2.2.2-r2.ebuild
@@ -1,52 +1,130 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/openmotif/openmotif-2.2.2-r2.ebuild,v 1.2 2003/06/07 03:23:28 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/openmotif/openmotif-2.2.2-r2.ebuild,v 1.3 2003/06/14 10:17:20 seemant Exp $
inherit libtool
MY_P=${P/m/M}
S=${WORKDIR}/${MY_P}
-DESCRIPTION="OpenMotif is a defacto standard graphical user interface on Unix and Unix-like systems"
+DESCRIPTION="Open Motif"
HOMEPAGE="http://www.motifzone.org/"
SRC_URI="ftp://ftp.sgi.com/other/motifzone/2.2/src/${MY_P}.tar.gz"
SLOT="0"
LICENSE="MOTIF"
-KEYWORDS="x86 ppc ~sparc alpha"
+KEYWORDS="~x86 ~ppc ~sparc"
PROVIDE="virtual/motif"
-DEPEND="virtual/glibc
- virtual/x11"
+RDEPEND="virtual/x11"
+DEPEND=">=sys-apps/sed-4"
src_unpack() {
+ local f list
+
unpack ${A}
cd ${S}
- epatch ${FILESDIR}/animate-demo.diff
- epatch ${FILESDIR}/include-order.diff
-}
+
+ #
+ # Don't compile/install demo programs.
+ # They're meant to demonstrate programming techniques and features
+ # of motif, but are of limited to no use for end users. Further,
+ # those progs that demonstrate Uil/Mrm functionality won't even work
+ # because their data(.uid) files are installed in nonstandard places,
+ # /usr/X11R6/share/Xm/<progname> (see `man MrmOpenHierarchy' for
+ # locations Mrm expects them to be). Most of the demos also don't
+ # have compiled in fallback resources and will not work correctly
+ # without their app-defaults files installed.
+ #
+ # So there a basically 4 choices:
+ # a) add wrappers that set XAPPLRESDIR and UIDPATH,
+ # b) clutter two more system directories with demo related files,
+ # c) put sources, data, binaries AND wrappers in
+ # /usr/X11R6/share/Xm/ (move this to X11R6/lib/X11/Xm/demos ?),
+ # OR
+ # D) don't install them at all.
+ #
+ #
+ ebegin "patching configure.in (no-demos patch)..."
+ sed -i 's:^\(demos/.*\):dnl \1:g' configure.in
+ eend $?
-src_compile() {
+ ebegin "patching toplevel Makefile.am (no-demos patch)..."
+ sed -i -e 's/\(\s*doc\) \\$/\1/' -e '/\s*demos$/d' Makefile.am
+ eend $?
+
+ #
+ # fix include order (#6536):
+ # This replaces `include-order.diff'. Had to change this patch so
+ # it modifies Makefile.am instead of Makefile.in because rerunning
+ # autotools below would undo any changes made to Makefile.in.
+ # Added `clients/mwm/WmWsmLib/' to the list.
+ #
+ ebegin "fixing include order..."
+ list="tools/wml/Makefile.am clients/mwm/WmWsmLib/Makefile.am"
+ for f in ${list}; do
+ einfo " ...${f}"
+ sed -i 's:\(^INCLUDES =\) \(\${X_CFLAGS}\) \(.*\):\1 \3 \2:' ${f}
+ done
+ eend $?
+ unset f list
+
+ #
+ # move `system.mwmrc' from /usr/X11R6/lib/X11 to /etc/X11/mwm (FHS).
+ # Just symlinking `system.mwmrc' isn't enough here because mwm
+ # also looks for localized verions in `$LANG/system.mwmrc'.
+ # Instead, this patch changes the default location from
+ # `/usr/X11R6/lib/X11/' to `/usr/X11R6/lib/X11/mwm/', which will
+ # be symlinked to /etc/X11/mwm/ in src_install().
+ #
+ epatch "$FILESDIR/mwm-configdir.patch"
+
+ #
+ # missing srcfile in demos/programs/animate
+ #
+ #einfo "creating missing file demos/programs/animate/animate.c"
+ #touch demos/programs/animate/animate.c
+
+ #
+ # Rebuild libtool (#15119, #20540, #21681)
+ #
elibtoolize
+ #
+ # Rebuild configure, Makefile.in
+ #
+ einfo " ...aclocal..."
+ aclocal || die "aclocal failed"
+ einfo " ...automake..."
+ automake --foreign || die "automake failed"
+ einfo " ...autoconf..."
+ autoconf || die "autoconf failed"
+}
+
+
+src_compile() {
# get around some LANG problems in make (#15119)
unset LANG
-
- econf \
+
+ ./configure \
--prefix=/usr/X11R6 \
--sysconfdir=/etc/X11 \
--with-x \
- --with-gnu-ld || die
+ --with-gnu-ld \
+ --host=${CHOST} || die "configuration failed"
make || die "make failed"
}
+
src_install() {
- make DESTDIR=${D} VARDIR=${D}/var/X11/ install || die "install failed"
+ local f list
- prepman /usr/X11R6
+ make \
+ DESTDIR=${D} \
+ VARDIR=${D}/var/X11/ install || die "make install failed"
#
# patch manpages to reflect actual location of configuration files
@@ -55,24 +133,38 @@ src_install() {
list="/usr/X11R6/man/man1/mwm.1 /usr/X11R6/man/man4/mwmrc.4"
for f in $list; do
einfo " ...${D}/$f"
- dosed 's:/usr/X11R6/lib/X11/\(.*system\\&\.mwmrc\):/etc/X11/mwm/\1:g' \
- "$f"
- dosed 's:/usr/X11R6/lib/X11/app-defaults:/etc/X11/app-defaults:g' \
- "$f"
+ dosed 's:/usr/X11R6/lib/X11/\(.*system\\&\.mwmrc\):/etc/X11/mwm/\1:g' "$f"
+ dosed 's:/usr/X11R6/lib/X11/app-defaults:/etc/X11/app-defaults:g' "$f"
done
unset f list
+ #
+ # prepallman looks for manpages in /usr/X11R6/share/man while X11 uses
+ # /usr/X11R6/man, so we'll have to compress them ourselves...
+ #
+ einfo "gzipping manpages..."
+ prepman "/usr/X11R6"
+
+ #
+ # move system.mwmrc & create symlink
+ #
+ einfo "moving system.mwmrc..."
+ dodir "/etc/X11/mwm"
+ mv "${D}/usr/X11R6/lib/X11/system.mwmrc" \
+ "${D}/etc/X11/mwm/system.mwmrc" || die "mv system.mwmrc"
+ ln -s "../../../../etc/X11/mwm" \
+ "${D}/usr/X11R6/lib/X11/mwm" || die "ln -s confdir"
- # Move the system.mwmrc and create symlink
- dodir /etc/X11/mwm
- mv ${D}/usr/X11R6/lib/X11/mwm/system.mwmrc $D}/etc/X11/mwm
- dosym ../../../../etc/X11/mwm/system.mwmrc /usr/X11R6/lib/X11/mwm
-
- # upstream does not include an app-defaults/Mwm file any longer with
- # 2.2.2
+ #
+ # app-defaults/Mwm isn't included anymore as of 2.2.2
+ #
+ einfo "creating mwm app-defaults file..."
insinto /etc/X11/app-defaults
newins ${FILESDIR}/Mwm.defaults Mwm
- dodoc COPYRIGHT* LICENSE* RE* *BUG*
+ einfo "installing docs..."
+ dodoc COPYRIGHT.MOTIF LICENSE
+ dodoc README RELEASE RELNOTES
+ dodoc BUGREPORT OPENBUGS CLOSEDBUGS
}