summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2001-12-30 17:29:05 +0000
committerDan Armak <danarmak@gentoo.org>2001-12-30 17:29:05 +0000
commita93a3fefc9a4724ad173a5fcf09cc9f6580c28c5 (patch)
treef9ef6e10bd13814bb9c2fdf0177b5d4c76888bd1 /x11-libs
parentupdated to latest version (diff)
downloadhistorical-a93a3fefc9a4724ad173a5fcf09cc9f6580c28c5.tar.gz
historical-a93a3fefc9a4724ad173a5fcf09cc9f6580c28c5.tar.bz2
historical-a93a3fefc9a4724ad173a5fcf09cc9f6580c28c5.zip
new: x11-libs/qt-3.0.1 ebuild; app-doc/qt-docs 2.3.1 and 3.0.1 ebuilds.
also a few fixes for misc stuff.
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/qt/qt-2.3.1.ebuild19
-rw-r--r--x11-libs/qt/qt-3.0.1.ebuild108
2 files changed, 118 insertions, 9 deletions
diff --git a/x11-libs/qt/qt-2.3.1.ebuild b/x11-libs/qt/qt-2.3.1.ebuild
index a8969c5095c4..fc7b45a02b80 100644
--- a/x11-libs/qt/qt-2.3.1.ebuild
+++ b/x11-libs/qt/qt-2.3.1.ebuild
@@ -1,19 +1,23 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Philippe Namias <pnamias@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/qt-2.3.1.ebuild,v 1.1 2001/12/29 17:41:37 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/qt-2.3.1.ebuild,v 1.2 2001/12/30 17:29:05 danarmak Exp $
S=${WORKDIR}/${P}
DESCRIPTION="QT ${PV}, an X11 widget set and general library used by KDE et al"
SRC_URI="ftp://ftp.trolltech.com/pub/qt/source/qt-x11-${PV}.tar.gz"
HOMEPAGE="http://www.trolltech.com/"
-DEPEND=">=media-libs/libpng-1.0.9
+RDEPEND=">=media-libs/libpng-1.0.9
>=media-libs/libmng-1.0.0
opengl? ( virtual/opengl virtual/glu )
nas? ( >=media-libs/nas-1.4.1 )
virtual/x11"
+DEPEND="$RDEPEND
+ sys-devel/gcc"
+
+QTBASE=/usr/qt/2
export QTDIR=${S}
src_unpack() {
@@ -40,7 +44,7 @@ src_compile() {
use opengl || myconf="$myconf -no-opengl"
use nas && myconf="${myconf} -system-nas-sound" || myconf="${myconf} -no-nas-sound"
use gif && myconf="${myconf} -gif"
- "$DEBUG" && myconf="${myconf} -debug" || myconf="${myconf} -release"
+ [ -n "$DEBUG" ] && myconf="${myconf} -debug" || myconf="${myconf} -release"
./configure -sm -thread -system-zlib -system-jpeg ${myconf} \
-system-libmng -system-libpng -gif -platform linux-g++ \
@@ -53,17 +57,14 @@ src_compile() {
src_install() {
- QTBASE=/usr/qt/2
cd ${S}
-
+
# binaries
into $QTBASE
dobin bin/*
# libraries
dolib lib/libqt.so.${PV} lib/libqt-mt.so.${PV} lib/libqutil.so.1.0.0
- # doesn't create all necessary symlinks :-(
- #preplib $QTBASE
cd ${D}$QTBASE/lib
for x in libqt.so libqt-mt.so
do
@@ -74,12 +75,12 @@ src_install() {
ln -s libqutil.so.1.0.0 libqutil.so.1.0
ln -s libqutil.so.1.0 libqutil.so.1
ln -s libqutil.so.1 libqutil.so
-
+
# includes
cd ${S}
dodir ${QTBASE}/include
cp include/* ${D}/${QTBASE}/include/
-
+
# misc
insinto /etc/env.d
doins ${FILESDIR}/50qt2
diff --git a/x11-libs/qt/qt-3.0.1.ebuild b/x11-libs/qt/qt-3.0.1.ebuild
new file mode 100644
index 000000000000..f76977fe467e
--- /dev/null
+++ b/x11-libs/qt/qt-3.0.1.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Dan Armak <danarmak@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/qt-3.0.1.ebuild,v 1.1 2001/12/30 17:29:05 danarmak Exp $
+
+P=qt-x11-${PV}
+S=${WORKDIR}/qt-x11-free-${PV}
+
+DESCRIPTION="QT version ${PV}"
+
+SRC_URI="ftp://ftp.trolltech.com/pub/qt/source/qt-x11-free-${PV}.tar.gz"
+HOMEPAGE="http://www.trolltech.com/"
+
+DEPEND=">=media-libs/libpng-1.0.9
+ >=media-libs/libmng-1.0.0
+ opengl? ( virtual/opengl virtual/glu )
+ nas? ( >=media-libs/nas-1.4.1 )
+ mysql? ( >=dev-db/mysql-3.2.10 )
+ odbc? ( >=dev-db/unixODBC-2.0 )
+ virtual/x11"
+
+QTBASE=/usr/qt/3
+export QTDIR=${S}
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+ cp configure configure.orig
+ sed -e "s:read acceptance:acceptance=yes:" configure.orig > configure
+
+ cd ${S}
+ mv tools/assistant/helpdialogimpl.cpp tools/assistant/helpdialogimpl.cpp_orig
+ sed -e 's:"/doc/html:"/share/doc/html:g' \
+ tools/assistant/helpdialogimpl.cpp_orig > tools/assistant/helpdialogimpl.cpp
+ mv tools/assistant/mainwindow.ui.h tools/assistant/mainwindow.ui.h_orig
+ sed -e 's:"/doc/html:"/share/doc/html:g' \
+ tools/assistant/mainwindow.ui.h_orig > tools/assistant/mainwindow.ui.h
+
+}
+
+src_compile() {
+
+ export LDFLAGS="-ldl"
+
+ use nas && myconf="${myconf} -system-nas-sound"
+ use gif && myconf="${myconf} -qt-gif"
+ use mysql && myconf="${myconf} -plugin-sql-mysql -I/usr/include/mysql -L/usr/lib/mysql"
+ use odbc && myconf="${myconf} -plugin-sql-odbc"
+ [ -n "$DEBUG" ] && myconf="${myconf} -debug" || myconf="${myconf} -release -no-g++-exceptions"
+
+ ./configure -sm -thread -stl -system-zlib -system-libjpeg ${myconf} \
+ -system-libmng -system-libpng -ldl -lpthread || die
+
+ emake src-qmake src-moc sub-src sub-tools || die
+
+}
+
+src_install() {
+
+ cd ${S}
+
+ # binaries
+ into $QTBASE
+ dobin bin/*
+
+ # libraries
+ dolib lib/libqt-mt.so.${PV} lib/libqui.so.1.0.0 lib/libeditor.so.1.0.0
+ cd ${D}$QTBASE/lib
+ for x in libqui.so libeditor.so
+ do
+ ln -s $x.1.0.0 $x.1.0
+ ln -s $x.1.0 $x.1
+ ln -s $x.1 $x
+ done
+ ln -s libqt-mt.so.3.0.1 libqt-mt.so.3.0
+ ln -s libqt-mt.so.3.0 libqt-mt.so.3
+ ln -s libqt-mt.so.3 libqt-mt.so
+
+ # includes
+ cd ${S}
+ dodir ${QTBASE}/include/private
+ cp include/* ${D}/${QTBASE}/include/
+ cp include/private/* ${D}/${QTBASE}/include/private/
+
+ # misc
+ insinto /etc/env.d
+ doins ${FILESDIR}/50qt2
+
+ # misc build reqs
+ dodir ${QTBASE}/mkspecs
+ cp -R ${S}/mkspecs/linux-g++ ${D}/${QTBASE}/mkspecs/
+
+ sed -e "s:${D}::g" \
+ -e "s:qt-x11-free-3.0.1::g" \
+ -e "s:${WORKDIR}:${QTBASE}:" \
+ -e "s:/usr/local/qt:${QTBASE}:" \
+ ${S}/.qmake.cache > ${D}${QTBASE}/.qmake.cache
+
+ # plugins
+ cd ${S}
+ plugins=`find plugins -name "lib*.so" -print`
+ for x in $plugins; do
+ insinto ${QTBASE}/`dirname $x`
+ doins $x
+ done
+
+}