summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-10-23 14:45:25 +0000
committerMike Frysinger <vapier@gentoo.org>2002-10-23 14:45:25 +0000
commitd030b9025d464841bf627f6023900fbde4fc2a30 (patch)
treea134929e739b18e0bdb9e0e972b480a2f2e7462b /x11-libs
parentnew ebuild going in (diff)
downloadhistorical-d030b9025d464841bf627f6023900fbde4fc2a30.tar.gz
historical-d030b9025d464841bf627f6023900fbde4fc2a30.tar.bz2
historical-d030b9025d464841bf627f6023900fbde4fc2a30.zip
Initial ebuild
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/xclass/ChangeLog8
-rw-r--r--x11-libs/xclass/files/digest-xclass-0.7.41
-rw-r--r--x11-libs/xclass/xclass-0.7.4.ebuild54
3 files changed, 63 insertions, 0 deletions
diff --git a/x11-libs/xclass/ChangeLog b/x11-libs/xclass/ChangeLog
new file mode 100644
index 000000000000..bcaa149be144
--- /dev/null
+++ b/x11-libs/xclass/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for x11-libs/xclass
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/xclass/ChangeLog,v 1.1 2002/10/23 14:45:25 vapier Exp $
+
+*xclass-0.7.4 (23 Oct 2002)
+
+ 23 Oct 2002; Mike Frysinger <vapier@gentoo.org> :
+ Initial import. Ebuild submitted by me.
diff --git a/x11-libs/xclass/files/digest-xclass-0.7.4 b/x11-libs/xclass/files/digest-xclass-0.7.4
new file mode 100644
index 000000000000..6d8e2ec6b975
--- /dev/null
+++ b/x11-libs/xclass/files/digest-xclass-0.7.4
@@ -0,0 +1 @@
+MD5 9f66e0812fa751ee6fc9d83c68e0a4a5 xclass-0.7.4.tar.gz 523626
diff --git a/x11-libs/xclass/xclass-0.7.4.ebuild b/x11-libs/xclass/xclass-0.7.4.ebuild
new file mode 100644
index 000000000000..34911ee7515b
--- /dev/null
+++ b/x11-libs/xclass/xclass-0.7.4.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/xclass/xclass-0.7.4.ebuild,v 1.1 2002/10/23 14:45:25 vapier Exp $
+
+IUSE=""
+DESCRIPTION="a C++ GUI toolkit for the X windows environment"
+HOMEPAGE="http://xclass.sourceforge.net/"
+SRC_URI="ftp://mitac11.uia.ac.be/pub/xclass/${P}.tar.gz"
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~sparc64 ~alpha"
+
+DEPEND="virtual/x11
+ virtual/glibc"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${P}"
+
+src_compile() {
+ econf --enable-shared=yes --with-x || die "configure failed"
+
+ # for some reason -fPIC dies while sandboxed ...
+ cd ${S}/lib/libxclass
+ cp Makefile Makefile.old
+ sed -e "s/shared: CXXFLAGS += -fPIC//" \
+ Makefile.old > Makefile
+
+ cd ${S}
+ if [ "`use static`" ] ; then
+ emake || die "'emake' failed"
+ else
+ emake shared || die "'emake shared' failed"
+ fi
+}
+
+src_install() {
+ cd ${S}
+ rm -rf `find . -name 'Makefile*'`
+
+ dobin config/xc-config
+
+ dodoc doc/*
+
+ dodir /usr/share/xclass
+ insinto /usr/share/xclass
+ mv "icons/Lock screen.s.xpm" ${D}/usr/share/xclass/
+ doins icons/*.xpm
+
+ dodir /usr/include/xclass
+ insinto /usr/include/xclass
+ doins include/xclass/*.h
+
+ dolib lib/libxclass/lib*
+}