summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBart Verwilst <verwilst@gentoo.org>2002-01-07 02:36:21 +0000
committerBart Verwilst <verwilst@gentoo.org>2002-01-07 02:36:21 +0000
commite29015f951a46f6a354b249949cc8d6cece8f1d7 (patch)
tree7cdedc6c5412e5737e3c1548764fea4266fd6193 /x11-libs
parentreadded the ldap-support since I unmasked the openldap. (diff)
downloadhistorical-e29015f951a46f6a354b249949cc8d6cece8f1d7.tar.gz
historical-e29015f951a46f6a354b249949cc8d6cece8f1d7.tar.bz2
historical-e29015f951a46f6a354b249949cc8d6cece8f1d7.zip
wxPython 2.3.2.1, initial ebuild
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/wxPython/files/digest-wxPython-2.3.2.11
-rw-r--r--x11-libs/wxPython/wxPython-2.3.2.1.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/x11-libs/wxPython/files/digest-wxPython-2.3.2.1 b/x11-libs/wxPython/files/digest-wxPython-2.3.2.1
new file mode 100644
index 000000000000..392b709d186c
--- /dev/null
+++ b/x11-libs/wxPython/files/digest-wxPython-2.3.2.1
@@ -0,0 +1 @@
+MD5 e57b4d030c4ba43a9030fdaee083011c wxPython-2.3.2.1.tar.gz 2846720
diff --git a/x11-libs/wxPython/wxPython-2.3.2.1.ebuild b/x11-libs/wxPython/wxPython-2.3.2.1.ebuild
new file mode 100644
index 000000000000..5117f382fb62
--- /dev/null
+++ b/x11-libs/wxPython/wxPython-2.3.2.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Tod Neidt <tneidt@fidnet.com>
+# $Header $
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="A blending of the wxWindows C++ class library with Python."
+
+SRC_URI="http://prdownloads.sourceforge.net/wxpython/${P}.tar.gz"
+
+HOMEPAGE="http://www.wxpython.org/"
+
+DEPEND=">=dev-lang/python-2.1
+ >=dev-libs/glib-1.2.5
+ >=x11-libs/gtk+-1.2.5
+ >=x11-libs/wxGTK-2.3.2"
+ #opengl? ( virtual/opengl )"
+ #really need opengl? ( virtual/opengl dev-python/PyOpenGL )
+ #to get full opengl functionality, i.e. wxGLCanvas.
+
+RDEPEND="${DEPEND}"
+
+src_compile() {
+
+ #local myconf
+ #myconf=""
+
+#Other possible configuration variables are BUILD_OGL and BUILD_STC.
+#BUILD_OGL builds the Object Graphics Library extension module.
+#BUILD_STC builds the wxStyledTextCtrl (the Scintilla wrapper) extension
+module.
+#Both these variable are enabled by default. To disable them set equal to
+zero
+#and add to myconf.
+
+ #use opengl || myconf="${myconf} BUILD_GLCANVAS=0"
+ #myconf="${myconf} BUILD_GLCANVAS=0"
+
+
+ python setup.py build ${myconf} || die
+
+}
+
+src_install () {
+
+ python setup.py install --prefix=${D}/usr || die
+
+ dodoc BUILD.unix.txt CHANGES.txt MANIFEST.in PKG-INFO README.txt
+
+}