summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2001-11-25 18:41:58 +0000
committerDan Armak <danarmak@gentoo.org>2001-11-25 18:41:58 +0000
commitfa90e454109d0021635b9b19e7f3a6a05df33f4d (patch)
tree496078f6cca83939e73bfc13188006a6a7eedf2e /x11-libs
parenta fix... KS defined incorrectly, resulting in a /usr/src/linux- directory. (diff)
downloadhistorical-fa90e454109d0021635b9b19e7f3a6a05df33f4d.tar.gz
historical-fa90e454109d0021635b9b19e7f3a6a05df33f4d.tar.bz2
historical-fa90e454109d0021635b9b19e7f3a6a05df33f4d.zip
numerous fixes, sync with bevin's version posted on gentoo-ebuild. great work, Bevin
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/qt-x11/qt-x11-3.0.0.ebuild66
1 files changed, 47 insertions, 19 deletions
diff --git a/x11-libs/qt-x11/qt-x11-3.0.0.ebuild b/x11-libs/qt-x11/qt-x11-3.0.0.ebuild
index 1418ac42f098..435ecd6a3741 100644
--- a/x11-libs/qt-x11/qt-x11-3.0.0.ebuild
+++ b/x11-libs/qt-x11/qt-x11-3.0.0.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Dan Armak <danarmak@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-x11/qt-x11-3.0.0.ebuild,v 1.4 2001/11/19 14:33:58 danarmak Exp $
+# /space/gentoo/cvsroot/gentoo-x86/x11-libs/qt-x11/qt-x11-3.0.0.ebuild,v 1.4 2001/11/19 14:33:58 danarmak Exp
P=qt-x11-${PV}
S=${WORKDIR}/qt-x11-free-${PV}
@@ -27,16 +27,25 @@ src_unpack() {
cp configure configure.orig
sed -e "s:read acceptance:acceptance=yes:" configure.orig > configure
- cd ${S}/mkspecs/linux-g++
- mv qmake.conf tmp
- echo "
-QMAKE_CFLAGS = ${CFLAGS}
-QMAKE_CXXFLAGS = ${CXXFLAGS}
-" > tmp2
- cat tmp tmp2 > qmake.conf
- rm tmp tmp2
+# cd ${S}/mkspecs/linux-g++
+# mv qmake.conf tmp
+# echo "
+#QMAKE_CFLAGS = ${CFLAGS}
+#QMAKE_CXXFLAGS = ${CXXFLAGS}
+#" > tmp2
+# cat tmp tmp2 > qmake.conf
+# rm tmp tmp2
use objprelink && patch -p0 < ${FILESDIR}/qt-x11-3-objprelink.patch
+
+ cd ${S}
+ mv tools/assistant/helpdialogimpl.cpp tools/assistant/helpdialogimpl.cpp_orig
+ sed -e 's:"/doc/html:"/share/doc/html:g' \
+ tools/assistant/helpdialogimpl.cpp_orig > tools/assistant/helpdialogimpl.cpp
+ mv tools/assistant/mainwindow.ui.h tools/assistant/mainwindow.ui.h_orig
+ sed -e 's:"/doc/html:"/share/doc/html:g' \
+ tools/assistant/mainwindow.ui.h_orig > tools/assistant/mainwindow.ui.h
+
}
src_compile() {
@@ -49,9 +58,10 @@ src_compile() {
[ "$DEBUG" ] && myconf="${myconf} -debug" || myconf="${myconf} -release -no-g++-exceptions"
./configure -sm -thread -stl -system-zlib -system-libjpeg ${myconf} \
- -system-libmng -system-libpng -ldl -lpthread -no-xft || die # -prefix ${D}/${QTBASE}
+ -system-libmng -system-libpng -ldl -lpthread -no-xft -prefix ${D}/${QTBASE} \
+ -docdir ${D}${QTBASE}/share/doc || die
- make || die
+ emake || die
}
@@ -61,16 +71,38 @@ src_install() {
mkdir -p ${D}${QTBASE}
cp -r examples tutorial ${D}${QTBASE}
- for x in bin lib include include/private; do
+ for x in bin include include/private; do
mkdir -p ${D}${QTBASE}/${x}
cd ${S}/${x}
- cp * ${D}${QTBASE}/${x}
+ cp -f * ${D}${QTBASE}/${x}
done
+
+ for x in lib mkspecs/linux-g++; do
+ mkdir -p ${D}${QTBASE}/${x}
+ cd ${S}/${x}
+ cp -af * ${D}${QTBASE}/${x}
+ done
+
+ sed -e "s:${D}::g" \
+ -e "s:qt-x11-free-3.0.0:qt-x11-3.0.0:g" \
+ -e "s:${WORKDIR}:${QTBASE}:" \
+ ${S}/.qmake.cache > ${D}${QTBASE}/.qmake.cache
cd ${S}
+ plugins=`find plugins -name "lib*.so" -print`
+ for x in $plugins; do
+ mkdir -p ${D}${QTBASE}/`dirname $x`
+ cp $x ${D}${QTBASE}/$x
+ done
+
+ cd ${S}
dodoc ANNOUNCE INSTALL FAQ LICENSE* MANIFEST PLATFORMS PORTING README* changes-*
- dodir ${QTBASE}/share/doc/
- cp -af ${S}/doc/html ${D}${QTBASE}/share/doc/
+ dodir ${QTBASE}/share
+ dodir ${QTBASE}/share/doc
+ cp -af ${S}/doc/man ${D}${QTBASE}/share
+ cp -af ${S}/doc/*.doc ${D}${QTBASE}/share/doc
+ cp -af ${S}/doc/html ${D}${QTBASE}/share/doc
+
cd ${D}
ln -s /${QTBASE} usr/lib/qt-x11-3
@@ -79,7 +111,3 @@ src_install() {
doins ${FILESDIR}/45qt-x11-3.0.0
}
-
-
-
-