summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2009-02-15 21:25:57 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2009-02-15 21:25:57 +0000
commitad124eb1bae0f5c235df223fe333ea3370b3f17e (patch)
treee4dbfa0acc73f4a9798611cb530fbc88cdecbee7 /x11-misc/periodic-calendar/periodic-calendar-2.3.ebuild
parentFix building on uClibc systems #222099 by Sergey Dryabzhinsky. (diff)
downloadhistorical-ad124eb1bae0f5c235df223fe333ea3370b3f17e.tar.gz
historical-ad124eb1bae0f5c235df223fe333ea3370b3f17e.tar.bz2
historical-ad124eb1bae0f5c235df223fe333ea3370b3f17e.zip
Bump per bug 251783 for gcc-4.3 compatibility. Thanks to Michael Mair-Keimberger <miki3@gmx.net>.
Package-Manager: portage-2.2_rc23/cvs/Linux x86_64
Diffstat (limited to 'x11-misc/periodic-calendar/periodic-calendar-2.3.ebuild')
-rw-r--r--x11-misc/periodic-calendar/periodic-calendar-2.3.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/x11-misc/periodic-calendar/periodic-calendar-2.3.ebuild b/x11-misc/periodic-calendar/periodic-calendar-2.3.ebuild
new file mode 100644
index 000000000000..92e267419fa5
--- /dev/null
+++ b/x11-misc/periodic-calendar/periodic-calendar-2.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/periodic-calendar/periodic-calendar-2.3.ebuild,v 1.1 2009/02/15 21:25:57 loki_val Exp $
+
+inherit gnome2 eutils
+
+MY_PN="PeriodicCalendar"
+MY_P=${MY_PN}-${PV}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="A GUI utility which assists in menstrual cycle tracking and fertility periods prediction."
+
+HOMEPAGE="http://linuxorg.sourceforge.net/"
+SRC_URI="mirror://sourceforge/linuxorg/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND=">=x11-libs/gtk+-2.1.0
+ >=gnome-base/gconf-1.1.11
+ >=dev-cpp/gtkmm-2.4.0
+ >=dev-cpp/libglademm-2.4.0"
+
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.29
+ >=app-text/scrollkeeper-0.1.4
+ dev-util/pkgconfig"
+
+DOCS="AUTHORS ChangeLog COPYING* INSTALL README"
+
+pkg_postinst() {
+ ewarn "It's probably a good idea that you read the documentation for this package."
+ ewarn "But just in case: From the README..."
+ echo
+ ewarn "At this point the fertility prediction is based on the calendar method"
+ ewarn "which is not very precise. It is not recommended to use this method alone"
+ ewarn "for the birth control."
+ ewarn "THIS PROGRAM PREDICTIONS IN NO CASES CAN BE USED AS THE FINAL. THE METHODS USE"
+ ewarn "ARE NOT 100% EFFECTIVE FOR ALL WOMEN."
+ echo
+ ebeep 3
+
+}