summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2010-08-09 16:44:42 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2010-08-09 16:44:42 +0000
commiteeefb46a842df902d730343903dbfd9df6c6353f (patch)
tree8cde7a659e1dff7a393a3d0db03f1c20bcccdd3c /x11-misc/xautolock/xautolock-2.1-r1.ebuild
parentRemove unnecessary KDE_MINIMAL, properly change SLOT (diff)
downloadhistorical-eeefb46a842df902d730343903dbfd9df6c6353f.tar.gz
historical-eeefb46a842df902d730343903dbfd9df6c6353f.tar.bz2
historical-eeefb46a842df902d730343903dbfd9df6c6353f.zip
Respect CC, CCFLAGS and LDFLAGS. Fixes bug 331789. Thanks Diego for the report
Package-Manager: portage-2.1.8.3/cvs/Linux x86_64
Diffstat (limited to 'x11-misc/xautolock/xautolock-2.1-r1.ebuild')
-rw-r--r--x11-misc/xautolock/xautolock-2.1-r1.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/x11-misc/xautolock/xautolock-2.1-r1.ebuild b/x11-misc/xautolock/xautolock-2.1-r1.ebuild
index 9d0e82ece288..414c357fc976 100644
--- a/x11-misc/xautolock/xautolock-2.1-r1.ebuild
+++ b/x11-misc/xautolock/xautolock-2.1-r1.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xautolock/xautolock-2.1-r1.ebuild,v 1.7 2008/05/24 13:36:16 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xautolock/xautolock-2.1-r1.ebuild,v 1.8 2010/08/09 16:44:42 xarthisius Exp $
+
+inherit toolchain-funcs
DESCRIPTION="An automatic X screen-locker/screen-saver."
SRC_URI="http://www.ibiblio.org/pub/Linux/X11/screensavers/${P}.tgz"
@@ -20,12 +22,12 @@ DEPEND="${RDEPEND}
src_compile() {
xmkmf || die
- emake || die
+ emake EXTRA_LDOPTIONS="${LDFLAGS}" CC="$(tc-getCC)" \
+ CDEBUGFLAGS="${CFLAGS}" || die
}
src_install () {
- into /usr
dobin xautolock || die
newman xautolock.man xautolock.1
- dodoc Changelog Readme Todo
+ dodoc Changelog Readme Todo || die
}