summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatti Bickel <mabi@gentoo.org>2008-10-04 12:01:45 +0000
committerMatti Bickel <mabi@gentoo.org>2008-10-04 12:01:45 +0000
commit6254e2b1f54ad640cafea4283cea261e589d439a (patch)
tree6c59a783ac8ea24319f52929e73cc25dda615e31 /x11-misc
parentChange c-ares USE flag to ares, as other packages already USE ares. (diff)
downloadhistorical-6254e2b1f54ad640cafea4283cea261e589d439a.tar.gz
historical-6254e2b1f54ad640cafea4283cea261e589d439a.tar.bz2
historical-6254e2b1f54ad640cafea4283cea261e589d439a.zip
version bump
Package-Manager: portage-2.2_rc11/cvs/Linux 2.6.23-gentoo-r3-20080120 ppc
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/xfe/ChangeLog9
-rw-r--r--x11-misc/xfe/xfe-1.19.2.ebuild34
2 files changed, 41 insertions, 2 deletions
diff --git a/x11-misc/xfe/ChangeLog b/x11-misc/xfe/ChangeLog
index a21f2b8f3044..a76b911886b9 100644
--- a/x11-misc/xfe/ChangeLog
+++ b/x11-misc/xfe/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/xfe
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xfe/ChangeLog,v 1.48 2007/11/21 18:21:11 nixnut Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xfe/ChangeLog,v 1.49 2008/10/04 12:01:45 mabi Exp $
+
+*xfe-1.19.2 (04 Oct 2008)
+
+ 04 Oct 2008; Matti Bickel <mabi@gentoo.org> +xfe-1.19.2.ebuild:
+ version bump, use EAPI 2 for use deps
21 Nov 2007; nixnut <nixnut@gentoo.org> xfe-1.04.ebuild:
Stable on ppc wrt bug 198932
diff --git a/x11-misc/xfe/xfe-1.19.2.ebuild b/x11-misc/xfe/xfe-1.19.2.ebuild
new file mode 100644
index 000000000000..6db225229ff5
--- /dev/null
+++ b/x11-misc/xfe/xfe-1.19.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xfe/xfe-1.19.2.ebuild,v 1.1 2008/10/04 12:01:45 mabi Exp $
+
+EAPI=2
+
+inherit eutils
+
+DESCRIPTION="MS-Explorer-like minimalist file manager for X"
+HOMEPAGE="http://roland65.free.fr/xfe"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug nls +png"
+
+DEPEND="=x11-libs/fox-1.6*[truetype,png?]
+ nls? ( sys-devel/gettext )"
+
+src_compile() {
+ econf $(use_enable nls) $(use_enable debug)
+ emake || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS BUGS ChangeLog README TODO
+ make_desktop_entry xfe "X File Explorer" xfe "System;FileTools;FileManager"
+ make_desktop_entry xfi "X File Image" xfi "System;FileTools"
+ make_desktop_entry xfp "X File Package" xfp "System;FileTools"
+ make_desktop_entry xfv "X File View" xfv "System;FileTools"
+ make_desktop_entry xfw "X File Write" xfw "System;FileTools"
+}