summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Loeser <halcy0n@gentoo.org>2005-12-28 20:04:24 +0000
committerMark Loeser <halcy0n@gentoo.org>2005-12-28 20:04:24 +0000
commite61bc86cda19f2720fabb1bb3362bec98adeccc1 (patch)
treec76529dcca6b310363ca2fb94c44606e1d28d867 /x11-misc
parentVersion bump. 0.2.4 stable on x86. (diff)
downloadhistorical-e61bc86cda19f2720fabb1bb3362bec98adeccc1.tar.gz
historical-e61bc86cda19f2720fabb1bb3362bec98adeccc1.tar.bz2
historical-e61bc86cda19f2720fabb1bb3362bec98adeccc1.zip
Add patch to fix compilation with gcc-4 by Brian Merrill <bmerrill AT sfcn DOT org>; bug #111321
Package-Manager: portage-2.1_pre2
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/xfe/ChangeLog7
-rw-r--r--x11-misc/xfe/Manifest10
-rw-r--r--x11-misc/xfe/files/xfe-0.84-gcc4.patch11
-rw-r--r--x11-misc/xfe/xfe-0.84.ebuild11
4 files changed, 37 insertions, 2 deletions
diff --git a/x11-misc/xfe/ChangeLog b/x11-misc/xfe/ChangeLog
index 363c7b89ba6a..f72a696a8ef6 100644
--- a/x11-misc/xfe/ChangeLog
+++ b/x11-misc/xfe/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/xfe
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xfe/ChangeLog,v 1.25 2005/08/07 13:17:31 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xfe/ChangeLog,v 1.26 2005/12/28 20:04:24 halcy0n Exp $
+
+ 28 Dec 2005; Mark Loeser <halcy0n@gentoo.org> +files/xfe-0.84-gcc4.patch,
+ xfe-0.84.ebuild:
+ Add patch to fix compilation with gcc-4 by Brian Merrill <bmerrill AT sfcn
+ DOT org>; bug #111321
07 Aug 2005; Michael Hanselmann <hansmi@gentoo.org> xfe-0.72.ebuild:
Stable on ppc.
diff --git a/x11-misc/xfe/Manifest b/x11-misc/xfe/Manifest
index 537013cdcf14..fe4979d0a957 100644
--- a/x11-misc/xfe/Manifest
+++ b/x11-misc/xfe/Manifest
@@ -1,3 +1,6 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
MD5 a13f1aae9a0b072ee3a4be6a343924c5 ChangeLog 3228
MD5 322d8f7e8c091743501a044efcd8dfe6 files/digest-xfe-0.72 60
MD5 f515eee36f5eafa1084a91e653ba0962 files/digest-xfe-0.80 60
@@ -8,3 +11,10 @@ MD5 cdb11033a3fa6525334cecf938961c07 metadata.xml 166
MD5 239a961941470ee8275f7f1663562222 xfe-0.72.ebuild 1032
MD5 75bec72fdc4d3c82106a96ecd55eb2e9 xfe-0.80.ebuild 860
MD5 9e359416ca16b9787dca81bfc99160e1 xfe-0.84.ebuild 1020
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.2 (GNU/Linux)
+
+iD8DBQFDsu/WCRZPokWLroQRAggJAJ9M4uF3GYj9aEQnt/GL23vULdaleQCgjo4S
+xVJ46z7g+GcKK5EFuAtcLN8=
+=Ggnh
+-----END PGP SIGNATURE-----
diff --git a/x11-misc/xfe/files/xfe-0.84-gcc4.patch b/x11-misc/xfe/files/xfe-0.84-gcc4.patch
new file mode 100644
index 000000000000..baa97ed5a9d1
--- /dev/null
+++ b/x11-misc/xfe/files/xfe-0.84-gcc4.patch
@@ -0,0 +1,11 @@
+--- xfe-0.84/src/FilePanel.cc 2005-11-02 23:30:56.000000000 -0700
++++ xfe-0.84/src/FilePanel.cc 2005-11-02 23:29:37.000000000 -0700
+@@ -296,7 +296,7 @@
+ {
+ FXString buf, filename, filepath;
+
+- int item= (int) ptr;
++ long item= (long) ptr;
+ if(item > -1)
+ {
+ // File name and path
diff --git a/x11-misc/xfe/xfe-0.84.ebuild b/x11-misc/xfe/xfe-0.84.ebuild
index d881e0b63d7b..4e6b7344ac4a 100644
--- a/x11-misc/xfe/xfe-0.84.ebuild
+++ b/x11-misc/xfe/xfe-0.84.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xfe/xfe-0.84.ebuild,v 1.1 2005/07/05 21:55:45 smithj Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xfe/xfe-0.84.ebuild,v 1.2 2005/12/28 20:04:24 halcy0n Exp $
+
+inherit eutils
DESCRIPTION="MS-Explorer-like minimalist file manager for X"
HOMEPAGE="http://roland65.free.fr/xfe/"
@@ -15,6 +17,13 @@ IUSE="nls"
DEPEND="virtual/x11
=x11-libs/fox-1.4*"
+src_unpack()
+{
+ unpack ${A}
+
+ epatch "${FILESDIR}"/${P}-gcc4.patch
+}
+
src_compile()
{
econf $(use_enable nls) || die "econf failed"