summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2009-12-19 13:42:31 +0000
committerPeter Volkov <pva@gentoo.org>2009-12-19 13:42:31 +0000
commitda149a2625ff0ff87049fa364b22dc51bb0a0d08 (patch)
treede5f82c17a5051f7790d7dbb13ec0f1ce994d11d /x11-plugins/pidgin-encryption/pidgin-encryption-3.0-r1.ebuild
parentVersion bump wrt #297515, thanks to Azamat H. Hackimov for reporting. (diff)
downloadhistorical-da149a2625ff0ff87049fa364b22dc51bb0a0d08.tar.gz
historical-da149a2625ff0ff87049fa364b22dc51bb0a0d08.tar.bz2
historical-da149a2625ff0ff87049fa364b22dc51bb0a0d08.zip
Added patch from debian to fix crash, hopefully fixes bug #292321, thank Phil Stracchino for good backtrace.
Package-Manager: portage-2.1.7.15/cvs/Linux x86_64
Diffstat (limited to 'x11-plugins/pidgin-encryption/pidgin-encryption-3.0-r1.ebuild')
-rw-r--r--x11-plugins/pidgin-encryption/pidgin-encryption-3.0-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/x11-plugins/pidgin-encryption/pidgin-encryption-3.0-r1.ebuild b/x11-plugins/pidgin-encryption/pidgin-encryption-3.0-r1.ebuild
new file mode 100644
index 000000000000..b3133cb68ed0
--- /dev/null
+++ b/x11-plugins/pidgin-encryption/pidgin-encryption-3.0-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-encryption/pidgin-encryption-3.0-r1.ebuild,v 1.1 2009/12/19 13:42:30 pva Exp $
+
+EAPI="2"
+
+inherit flag-o-matic eutils
+
+DESCRIPTION="Pidgin IM Encryption PlugIn"
+HOMEPAGE="http://pidgin-encrypt.sourceforge.net/"
+SRC_URI="mirror://sourceforge/gaim-encryption/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="nls"
+
+RDEPEND="net-im/pidgin
+ >=x11-libs/gtk+-2
+ >=dev-libs/nss-3.11"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-crash.patch"
+}
+
+src_configure() {
+ strip-flags
+ replace-flags -O? -O2
+ econf $(use_enable nls)
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die "Install failed"
+ dodoc CHANGELOG INSTALL NOTES README TODO VERSION WISHLIST
+}