summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Crête <tester@gentoo.org>2008-07-02 15:40:19 +0000
committerOlivier Crête <tester@gentoo.org>2008-07-02 15:40:19 +0000
commit3abfb89f9175aa78426e3fea8677dfaed8de7103 (patch)
treebddfceda50a574da6a3e246fbc80b4afdcff878a /x11-plugins/pidgin-otr/pidgin-otr-3.2.0.ebuild
parentVersion bump, cleanup old (diff)
downloadhistorical-3abfb89f9175aa78426e3fea8677dfaed8de7103.tar.gz
historical-3abfb89f9175aa78426e3fea8677dfaed8de7103.tar.bz2
historical-3abfb89f9175aa78426e3fea8677dfaed8de7103.zip
Version bump, cleanup old
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'x11-plugins/pidgin-otr/pidgin-otr-3.2.0.ebuild')
-rw-r--r--x11-plugins/pidgin-otr/pidgin-otr-3.2.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/x11-plugins/pidgin-otr/pidgin-otr-3.2.0.ebuild b/x11-plugins/pidgin-otr/pidgin-otr-3.2.0.ebuild
new file mode 100644
index 000000000000..afb8aba178ca
--- /dev/null
+++ b/x11-plugins/pidgin-otr/pidgin-otr-3.2.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-otr/pidgin-otr-3.2.0.ebuild,v 1.1 2008/07/02 15:40:19 tester Exp $
+
+inherit flag-o-matic eutils autotools
+
+DESCRIPTION="(OTR) Messaging allows you to have private conversations over instant messaging"
+HOMEPAGE="http://www.cypherpunks.ca/otr/"
+SRC_URI="http://www.cypherpunks.ca/otr/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=net-libs/libotr-3.2.0
+ >=x11-libs/gtk+-2
+ net-im/pidgin"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+pkg_setup() {
+ if ! built_with_use net-im/pidgin gtk; then
+ eerror "You need to compile net-im/pidgin with USE=gtk"
+ die "Missing gtk USE flag on net-im/pidgin"
+ fi
+}
+
+src_compile() {
+ strip-flags
+ replace-flags -O? -O2
+
+ econf || die "econf failed"
+ emake -j1 || die "Make failed"
+}
+
+src_install() {
+ emake -j1 install DESTDIR="${D}" || die "Install failed"
+ dodoc ChangeLog README
+}