summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2009-08-16 09:02:49 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2009-08-16 09:02:49 +0000
commit1b7914a101447a92578591b8b6f59afbaef181a0 (patch)
treec22eb0357590e31544d52832de857f10070a7cd0 /x11-plugins/pidgin-otr
parentRaise audacious dependency to >=1.5.0 so we can drop built_with_use. (diff)
downloadhistorical-1b7914a101447a92578591b8b6f59afbaef181a0.tar.gz
historical-1b7914a101447a92578591b8b6f59afbaef181a0.tar.bz2
historical-1b7914a101447a92578591b8b6f59afbaef181a0.zip
Migrate to EAPI 2 in order to drop built_with_use call.
Package-Manager: portage-2.2_rc38/cvs/Linux i686
Diffstat (limited to 'x11-plugins/pidgin-otr')
-rw-r--r--x11-plugins/pidgin-otr/ChangeLog8
-rw-r--r--x11-plugins/pidgin-otr/pidgin-otr-3.2.0.ebuild22
2 files changed, 16 insertions, 14 deletions
diff --git a/x11-plugins/pidgin-otr/ChangeLog b/x11-plugins/pidgin-otr/ChangeLog
index 0894c9558e2a..67bd7d5283f2 100644
--- a/x11-plugins/pidgin-otr/ChangeLog
+++ b/x11-plugins/pidgin-otr/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-plugins/pidgin-otr
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-otr/ChangeLog,v 1.14 2008/07/02 15:40:19 tester Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-otr/ChangeLog,v 1.15 2009/08/16 09:02:49 betelgeuse Exp $
+
+ 16 Aug 2009; Petteri Räty <betelgeuse@gentoo.org>
+ pidgin-otr-3.2.0.ebuild:
+ Migrate to EAPI 2 in order to drop built_with_use call.
*pidgin-otr-3.2.0 (02 Jul 2008)
diff --git a/x11-plugins/pidgin-otr/pidgin-otr-3.2.0.ebuild b/x11-plugins/pidgin-otr/pidgin-otr-3.2.0.ebuild
index afb8aba178ca..f4252168f017 100644
--- a/x11-plugins/pidgin-otr/pidgin-otr-3.2.0.ebuild
+++ b/x11-plugins/pidgin-otr/pidgin-otr-3.2.0.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-otr/pidgin-otr-3.2.0.ebuild,v 1.1 2008/07/02 15:40:19 tester Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-otr/pidgin-otr-3.2.0.ebuild,v 1.2 2009/08/16 09:02:49 betelgeuse Exp $
+
+EAPI="2"
inherit flag-o-matic eutils autotools
@@ -15,27 +17,23 @@ IUSE=""
RDEPEND=">=net-libs/libotr-3.2.0
>=x11-libs/gtk+-2
- net-im/pidgin"
+ net-im/pidgin[gtk]"
DEPEND="${RDEPEND}
dev-util/pkgconfig"
-pkg_setup() {
- if ! built_with_use net-im/pidgin gtk; then
- eerror "You need to compile net-im/pidgin with USE=gtk"
- die "Missing gtk USE flag on net-im/pidgin"
- fi
-}
-
-src_compile() {
+src_configure() {
strip-flags
replace-flags -O? -O2
econf || die "econf failed"
+}
+
+src_compile() {
emake -j1 || die "Make failed"
}
src_install() {
emake -j1 install DESTDIR="${D}" || die "Install failed"
- dodoc ChangeLog README
+ dodoc ChangeLog README || die
}