summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2002-10-04 15:15:52 +0000
committerNick Hadaway <raker@gentoo.org>2002-10-04 15:15:52 +0000
commit71aa533986b962a2b0c500001c050a843cf5d241 (patch)
tree5ac24e213fd8e9d9155d171e5a4b2162bb372427 /x11-plugins/wmdl
parentremove dep on cdrtools,cdrdao sinc koncd isn't built by default (i.e. there's... (diff)
downloadhistorical-71aa533986b962a2b0c500001c050a843cf5d241.tar.gz
historical-71aa533986b962a2b0c500001c050a843cf5d241.tar.bz2
historical-71aa533986b962a2b0c500001c050a843cf5d241.zip
Initial add of ebuild to portage. Again, no homepage. This time I
got the tarball from a .src.rpm :) I have copied the tarball to the ibiblio mirror directory.
Diffstat (limited to 'x11-plugins/wmdl')
-rw-r--r--x11-plugins/wmdl/ChangeLog11
-rw-r--r--x11-plugins/wmdl/files/digest-wmdl-1.4.11
-rw-r--r--x11-plugins/wmdl/files/makefile.diff44
-rw-r--r--x11-plugins/wmdl/wmdl-1.4.1.ebuild38
4 files changed, 94 insertions, 0 deletions
diff --git a/x11-plugins/wmdl/ChangeLog b/x11-plugins/wmdl/ChangeLog
new file mode 100644
index 000000000000..5ae8f9e33f15
--- /dev/null
+++ b/x11-plugins/wmdl/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for x11-plugins/wmdl
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmdl/ChangeLog,v 1.1 2002/10/04 15:15:52 raker Exp $
+
+*wmdl-1.4.1 (04 Oct 2002)
+
+ 04 Oct 2002; Nick Hadaway <raker@gentoo.org> wmdl-1.4.1.ebuild,
+ files/digest-wmdl-1.4.1, files/makefile.diff :
+ Initial add of ebuild to portage. Again, no homepage. This time I
+ got the tarball from a .src.rpm :) I have copied the tarball to the
+ ibiblio mirror directory.
diff --git a/x11-plugins/wmdl/files/digest-wmdl-1.4.1 b/x11-plugins/wmdl/files/digest-wmdl-1.4.1
new file mode 100644
index 000000000000..4be08395164b
--- /dev/null
+++ b/x11-plugins/wmdl/files/digest-wmdl-1.4.1
@@ -0,0 +1 @@
+MD5 9711d13cb738d1e2da16fa42a7292586 wmdl-1.4.1.tar.gz 45557
diff --git a/x11-plugins/wmdl/files/makefile.diff b/x11-plugins/wmdl/files/makefile.diff
new file mode 100644
index 000000000000..8081263b1f0d
--- /dev/null
+++ b/x11-plugins/wmdl/files/makefile.diff
@@ -0,0 +1,44 @@
+diff -urN wmdl-1.4.1/Makefile wmdl-1.4.1-modified/Makefile
+--- wmdl-1.4.1/Makefile 1999-11-14 12:56:47.000000000 -0600
++++ wmdl-1.4.1-modified/Makefile 2002-10-04 10:11:42.000000000 -0500
+@@ -1,12 +1,7 @@
+
+-INCLUDES = -I/usr/include \
+- -I/usr/local/include \
+- -I/usr/openwin/share/include/X11
+-
+-LIBINC = -L/usr/lib/X11 \
+- -L/usr/X11/lib \
+- -L/usr/X11R6/lib \
+- -L/usr/local/lib/X11
++INCLUDES =
++
++LIBINC = -L/usr/X11R6/lib
+
+ PIXMAPINC = -I./images
+
+@@ -14,10 +9,8 @@
+
+
+ CC=gcc
+-#CC=cc
+
+-#CFLAGS= -g --verbose
+-CFLAGS= -g
++FLAGS=${CFLAGS}
+
+ TARGET=wmdl
+ SOURCE=wmdl.c
+@@ -25,10 +18,10 @@
+ all: ${TARGET}
+
+ ${TARGET}: ${SOURCE}
+- $(CC) $(CFLAGS) -o ${TARGET} ${SOURCE} ${INCLUDES} ${LIBINC} ${PIXMAPINC} ${LIBS}
++ $(CC) $(FLAGS) -o ${TARGET} ${SOURCE} ${INCLUDES} ${LIBINC} ${PIXMAPINC} ${LIBS}
+
+ clean:
+ if [ -e wmdl ] ; then rm wmdl; fi
+
+ install:
+- if [ -e /usr/local/bin ] ; then cp wmdl /usr/local/bin ; fi
++ if [ -e /usr/bin ] ; then cp wmdl /usr/bin ; fi
diff --git a/x11-plugins/wmdl/wmdl-1.4.1.ebuild b/x11-plugins/wmdl/wmdl-1.4.1.ebuild
new file mode 100644
index 000000000000..f1302309ec29
--- /dev/null
+++ b/x11-plugins/wmdl/wmdl-1.4.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmdl/wmdl-1.4.1.ebuild,v 1.1 2002/10/04 15:15:52 raker Exp $
+
+S="${WORKDIR}/${P}"
+
+DESCRIPTION="WindowMaker Doom Load dockapp"
+HOMEPAGE="http://the.homepage.doesnt.appear.to.exist.anymore.com"
+SRC_URI="http://www.ibiblio.org/pub/linux/distributions/gentoo/distfiles/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="virtual/glibc
+ virtual/x11"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+ patch -p1 < ${FILESDIR}/makefile.diff || die "patch failed"
+
+}
+
+src_compile() {
+
+ make || die "parallel make failed"
+
+}
+
+src_install() {
+
+ cd ${S}
+ dobin wmdl
+
+}