summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2007-07-20 14:49:18 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2007-07-20 14:49:18 +0000
commit8323ad85b0dfe163bb2ddc4699d5ec25a7106b71 (patch)
tree3a842decad511c055b0af8a7e7b2fd594f969384 /x11-plugins/wmwork/wmwork-0.2.5.ebuild
parentStrip flags, as upstream requested (diff)
downloadhistorical-8323ad85b0dfe163bb2ddc4699d5ec25a7106b71.tar.gz
historical-8323ad85b0dfe163bb2ddc4699d5ec25a7106b71.tar.bz2
historical-8323ad85b0dfe163bb2ddc4699d5ec25a7106b71.zip
Initial import, closes bug 182225
Package-Manager: portage-2.1.2.9
Diffstat (limited to 'x11-plugins/wmwork/wmwork-0.2.5.ebuild')
-rw-r--r--x11-plugins/wmwork/wmwork-0.2.5.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/x11-plugins/wmwork/wmwork-0.2.5.ebuild b/x11-plugins/wmwork/wmwork-0.2.5.ebuild
new file mode 100644
index 000000000000..b5f3cca89cf8
--- /dev/null
+++ b/x11-plugins/wmwork/wmwork-0.2.5.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmwork/wmwork-0.2.5.ebuild,v 1.1 2007/07/20 14:49:18 s4t4n Exp $
+
+inherit eutils
+
+DESCRIPTION="Dock-app that lets you easily track time spent on different projects."
+HOMEPAGE="http://www.godisch.de/debian/wmwork/"
+SRC_URI="http://www.godisch.de/debian/wmwork/$P.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND=">=x11-libs/libXext-1.0.3
+ >=x11-libs/libX11-1.1.1-r1
+ >=x11-libs/libXpm-3.5.6"
+
+src_compile() {
+ cd src
+ econf || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ dodoc README CHANGES
+ cd src
+ emake DESTDIR="${D}" install || die "emake install failed"
+ doman wmwork.1 || die "doman failed"
+}