summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2004-08-26 22:27:09 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2004-08-26 22:27:09 +0000
commit5a315398bcfefcd604b77a2b59f20c55a0ab4d0f (patch)
tree45af04188d3d2f46b524132d7ab303302be8ed1c /x11-plugins/wmxres/wmxres-1.2.ebuild
parentInitial import of x11-plugins/wmhdplop, version 0.9.6. Closes #61808 (diff)
downloadhistorical-5a315398bcfefcd604b77a2b59f20c55a0ab4d0f.tar.gz
historical-5a315398bcfefcd604b77a2b59f20c55a0ab4d0f.tar.bz2
historical-5a315398bcfefcd604b77a2b59f20c55a0ab4d0f.zip
Initial import of x11-plugins/wmxres, version 1.2. Closes #61448
Diffstat (limited to 'x11-plugins/wmxres/wmxres-1.2.ebuild')
-rw-r--r--x11-plugins/wmxres/wmxres-1.2.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/x11-plugins/wmxres/wmxres-1.2.ebuild b/x11-plugins/wmxres/wmxres-1.2.ebuild
new file mode 100644
index 000000000000..428474ed89a9
--- /dev/null
+++ b/x11-plugins/wmxres/wmxres-1.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmxres/wmxres-1.2.ebuild,v 1.1 2004/08/26 22:27:09 s4t4n Exp $
+
+inherit eutils
+
+IUSE=""
+
+DESCRIPTION="Dock application to select your display mode among those possible"
+SRC_URI="http://yalla.free.fr/wn/${PN}-1.1-0.tar.gz"
+HOMEPAGE="http://yalla.free.fr/wn/"
+
+DEPEND="virtual/x11"
+
+SLOT="0"
+LICENSE="GPL-1"
+KEYWORDS="~x86"
+
+S="${WORKDIR}/${PN}.app"
+
+src_unpack() {
+
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/${PN}-makefile.patch
+ epatch ${FILESDIR}/${PN}-debian-1.1-1.2.patch
+
+}
+
+src_compile() {
+
+ emake GCFLAGS="${CFLAGS}" || die "make failed"
+
+}
+
+src_install() {
+
+ dobin ${PN}/${PN}
+ doman ${PN}.1
+
+ insinto /usr/share/applications
+ doins ${FILESDIR}/${PN}.desktop
+
+}