summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDon Seiler <rizzo@gentoo.org>2005-01-08 05:16:11 +0000
committerDon Seiler <rizzo@gentoo.org>2005-01-08 05:16:11 +0000
commit7ac4ef6e4248fe315a01354d153d75fe3241c7a2 (patch)
tree369a6c77234bb51fc30e486d1c8e278c75da2096 /x11-plugins
parentFixing MOZILLA_CONFIG errors that I'll surely be getting in about 30 minutes. (diff)
downloadhistorical-7ac4ef6e4248fe315a01354d153d75fe3241c7a2.tar.gz
historical-7ac4ef6e4248fe315a01354d153d75fe3241c7a2.tar.bz2
historical-7ac4ef6e4248fe315a01354d153d75fe3241c7a2.zip
Some patches, hopefully addresses bug #77073
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/guifications/Manifest4
-rw-r--r--x11-plugins/guifications/files/digest-guifications-2.7-r11
-rw-r--r--x11-plugins/guifications/files/gf_notification.diff16
-rw-r--r--x11-plugins/guifications/files/guifications-2.8cvs-font_fix_take_2.diff19
-rw-r--r--x11-plugins/guifications/guifications-2.7-r1.ebuild37
5 files changed, 77 insertions, 0 deletions
diff --git a/x11-plugins/guifications/Manifest b/x11-plugins/guifications/Manifest
index 4baea6921cf7..1cac4efa4c98 100644
--- a/x11-plugins/guifications/Manifest
+++ b/x11-plugins/guifications/Manifest
@@ -2,5 +2,9 @@ MD5 b064fa23bab32696c0b4e7e4fa881fe0 ChangeLog 4244
MD5 ef561a7c4bf0937ca8896c33015ff956 guifications-2.7.ebuild 835
MD5 4963e54c0bba1b55104563e88ab5046d guifications-2.6.ebuild 834
MD5 8d08e9a7e45330b731e02aadc8acb6fc metadata.xml 354
+MD5 c8ade3e791f24331edf80afac59634a6 guifications-2.7-r1.ebuild 996
MD5 d0ea8d9dddea012a994a07427927c68e files/digest-guifications-2.7 69
MD5 84647f96430d1bc05402a280fa68fded files/digest-guifications-2.6 69
+MD5 d0ea8d9dddea012a994a07427927c68e files/digest-guifications-2.7-r1 69
+MD5 b85a160efb3845b976bd04a204a8a4bb files/gf_notification.diff 745
+MD5 39dbb6d5053a23dc5ff31ee01d49f02d files/guifications-2.8cvs-font_fix_take_2.diff 700
diff --git a/x11-plugins/guifications/files/digest-guifications-2.7-r1 b/x11-plugins/guifications/files/digest-guifications-2.7-r1
new file mode 100644
index 000000000000..de4d61d535a7
--- /dev/null
+++ b/x11-plugins/guifications/files/digest-guifications-2.7-r1
@@ -0,0 +1 @@
+MD5 c4bd7f3a55cdc8db931c358a4d378147 guifications-2.7.tar.bz2 583875
diff --git a/x11-plugins/guifications/files/gf_notification.diff b/x11-plugins/guifications/files/gf_notification.diff
new file mode 100644
index 000000000000..a89051275943
--- /dev/null
+++ b/x11-plugins/guifications/files/gf_notification.diff
@@ -0,0 +1,16 @@
+===================================================================
+RCS file: /cvsroot/guifications/guifications2/src/gf_notification.c,v
+retrieving revision 1.45
+retrieving revision 1.46
+diff -u -r1.45 -r1.46
+--- guifications/guifications2/src/gf_notification.c 2005/01/01 01:06:38 1.45
++++ guifications/guifications2/src/gf_notification.c 2005/01/07 20:42:56 1.46
+@@ -163,7 +163,7 @@
+ parent = xmlnode_new("notification");
+ xmlnode_set_attrib(parent, "type", notification->n_type);
+
+- xmlnode_set_attrib(parent, "type", (notification->use_gtk) ? "1" : "0");
++ xmlnode_set_attrib(parent, "use_gtk", (notification->use_gtk) ? "1" : "0");
+
+ if(notification->background)
+ xmlnode_set_attrib(parent, "background", notification->background);
diff --git a/x11-plugins/guifications/files/guifications-2.8cvs-font_fix_take_2.diff b/x11-plugins/guifications/files/guifications-2.8cvs-font_fix_take_2.diff
new file mode 100644
index 000000000000..56c56caa7aa1
--- /dev/null
+++ b/x11-plugins/guifications/files/guifications-2.8cvs-font_fix_take_2.diff
@@ -0,0 +1,19 @@
+Index: src/gf_gtk_utils.c
+===================================================================
+RCS file: /cvsroot/guifications/guifications2/src/gf_gtk_utils.c,v
+retrieving revision 1.2
+diff -u -p -r1.2 gf_gtk_utils.c
+--- src/gf_gtk_utils.c 1 Jan 2005 01:06:37 -0000 1.2
++++ src/gf_gtk_utils.c 8 Jan 2005 02:46:21 -0000
+@@ -94,6 +94,12 @@ gf_gtk_theme_get_font() {
+
+ style = gtk_rc_get_style(style_widget);
+
++ if(!pango_font_description_get_family(style->font_desc))
++ pango_font_description_set_family(style->font_desc, "Sans");
++
++ if(pango_font_description_get_size(style->font_desc) <= 0)
++ pango_font_description_set_size(style->font_desc, 10 * PANGO_SCALE);
++
+ return style->font_desc;
+ }
diff --git a/x11-plugins/guifications/guifications-2.7-r1.ebuild b/x11-plugins/guifications/guifications-2.7-r1.ebuild
new file mode 100644
index 000000000000..13fe70c9293c
--- /dev/null
+++ b/x11-plugins/guifications/guifications-2.7-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/guifications/guifications-2.7-r1.ebuild,v 1.1 2005/01/08 05:16:11 rizzo Exp $
+
+inherit eutils
+
+DESCRIPTION="Guifications are graphical notification plugin for the open source instant message client gaim"
+HOMEPAGE="http://guifications.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc ~sparc"
+IUSE="debug"
+
+DEPEND=">=net-im/gaim-1.0.0"
+#RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/gf_notification.diff
+ epatch ${FILESDIR}/guifications-2.8cvs-font_fix_take_2.diff
+}
+
+src_compile() {
+ local myconf
+ myconf=`use_enable debug`
+
+ econf ${myconf} || die "econf failure"
+ emake || die "emake failure"
+}
+
+src_install() {
+ make install DESTDIR=${D} || die "make install failure"
+ dodoc ABOUT-NLS AUTHORS COPYING ChangeLog INSTALL NEWS README TODO VERSION
+}