summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2005-08-10 05:35:09 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2005-08-10 05:35:09 +0000
commit286fa4c1c4695db72e025a50ebad1d43f6570dda (patch)
treeebbbee04c99df4b4bfa766798ac00ac851d516c8 /x11-proto/glproto
parentremove bogus digest file -KS (diff)
downloadhistorical-286fa4c1c4695db72e025a50ebad1d43f6570dda.tar.gz
historical-286fa4c1c4695db72e025a50ebad1d43f6570dda.tar.bz2
historical-286fa4c1c4695db72e025a50ebad1d43f6570dda.zip
Make compatible with opengl-update. Reported by Georgi Georgiev <chutz@gg3.net>.
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'x11-proto/glproto')
-rw-r--r--x11-proto/glproto/ChangeLog6
-rw-r--r--x11-proto/glproto/Manifest4
-rw-r--r--x11-proto/glproto/glproto-1.4.ebuild26
3 files changed, 32 insertions, 4 deletions
diff --git a/x11-proto/glproto/ChangeLog b/x11-proto/glproto/ChangeLog
index 992baec5d960..03425c8923e5 100644
--- a/x11-proto/glproto/ChangeLog
+++ b/x11-proto/glproto/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-proto/glproto
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-proto/glproto/ChangeLog,v 1.2 2005/08/08 17:54:50 fmccor Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-proto/glproto/ChangeLog,v 1.3 2005/08/10 05:35:09 spyderous Exp $
+
+ 10 Aug 2005; Donnie Berkholz <spyderous@gentoo.org>; glproto-1.4.ebuild:
+ Make compatible with opengl-update. Reported by Georgi Georgiev
+ <chutz@gg3.net>.
08 Aug 2005; Ferris McCormick <fmccor@gentoo.org> glproto-1.4.ebuild:
Add ~sparc keyword (modular X testing on sparc).
diff --git a/x11-proto/glproto/Manifest b/x11-proto/glproto/Manifest
index 589ae07ebfac..10d6c8534e78 100644
--- a/x11-proto/glproto/Manifest
+++ b/x11-proto/glproto/Manifest
@@ -1,3 +1,3 @@
-MD5 79ff72c9c356afbdac578ab36872b87b ChangeLog 467
-MD5 99a79eaeb0277c4e16186289ca010a88 glproto-1.4.ebuild 500
+MD5 5082e470e79cecc16982c9d68edec8d9 glproto-1.4.ebuild 1093
+MD5 d3682de20a75f88301e44468c0efff70 ChangeLog 631
MD5 6a9182efc5f985cb40b92436c638034b files/digest-glproto-1.4 63
diff --git a/x11-proto/glproto/glproto-1.4.ebuild b/x11-proto/glproto/glproto-1.4.ebuild
index 5017eb4f5cea..41b40dd7314a 100644
--- a/x11-proto/glproto/glproto-1.4.ebuild
+++ b/x11-proto/glproto/glproto-1.4.ebuild
@@ -1,12 +1,14 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-proto/glproto/glproto-1.4.ebuild,v 1.2 2005/08/08 17:54:50 fmccor Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-proto/glproto/glproto-1.4.ebuild,v 1.3 2005/08/10 05:35:09 spyderous Exp $
# Must be before x-modular eclass is inherited
#SNAPSHOT="yes"
inherit x-modular
+OPENGL_DIR="xorg-x11"
+
DESCRIPTION="X.Org GL protocol headers"
#HOMEPAGE="http://foo.bar.com/"
#SRC_URI="ftp://foo.bar.com/${P}.tar.bz2"
@@ -16,3 +18,25 @@ KEYWORDS="~sparc ~x86"
#IUSE="X gnome"
#DEPEND=""
#RDEPEND=""
+
+src_install() {
+ x-modular_src_install
+
+ dynamic_libgl_install
+}
+
+dynamic_libgl_install() {
+ # next section is to setup the dynamic libGL stuff
+ ebegin "Moving GL files for dynamic switching"
+ dodir /usr/$(get_libdir)/opengl/${OPENGL_DIR}/include
+ local x=""
+ # glext.h added for #54984
+ # glx.h also provided by mesa, so we don't add it
+ rm ${D}/usr/include/GL/glx.h
+ for x in ${D}/usr/include/GL/{glxtokens.h,glxmd.h,glxproto.h}; do
+ if [ -f ${x} -o -L ${x} ]; then
+ mv -f ${x} ${D}/usr/$(get_libdir)/opengl/${OPENGL_DIR}/include
+ fi
+ done
+ eend 0
+}