summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2008-06-20 18:01:50 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2008-06-20 18:01:50 +0000
commit85c75f2e6fce33e76a9bfe0c3f4a3d8581f5f386 (patch)
tree2266969a06f8a975ff739bee2643ddadf61180b9 /x11-terms/kterm/kterm-6.2.0-r5.ebuild
parentAdded scm ebuild for testing. (diff)
downloadhistorical-85c75f2e6fce33e76a9bfe0c3f4a3d8581f5f386.tar.gz
historical-85c75f2e6fce33e76a9bfe0c3f4a3d8581f5f386.tar.bz2
historical-85c75f2e6fce33e76a9bfe0c3f4a3d8581f5f386.zip
Fixed dependency, bug #227563. Removed bindnow-flags, bug #227031.
Package-Manager: portage-2.1.5_rc6
Diffstat (limited to 'x11-terms/kterm/kterm-6.2.0-r5.ebuild')
-rw-r--r--x11-terms/kterm/kterm-6.2.0-r5.ebuild81
1 files changed, 81 insertions, 0 deletions
diff --git a/x11-terms/kterm/kterm-6.2.0-r5.ebuild b/x11-terms/kterm/kterm-6.2.0-r5.ebuild
new file mode 100644
index 000000000000..60e7eb447632
--- /dev/null
+++ b/x11-terms/kterm/kterm-6.2.0-r5.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/kterm/kterm-6.2.0-r5.ebuild,v 1.1 2008/06/20 18:01:50 matsuu Exp $
+
+inherit eutils flag-o-matic toolchain-funcs
+
+IUSE="Xaw3d"
+
+DESCRIPTION="Japanese Kanji X Terminal"
+SRC_URI="ftp://ftp.x.org/contrib/applications/${P}.tar.gz
+ http://www.asahi-net.or.jp/~hc3j-tkg/kterm/${P}-wpi.patch.gz
+ http://www.st.rim.or.jp/~hanataka/${P}.ext02.patch.gz"
+# until someone who reads japanese can find a better place
+HOMEPAGE="http://www.asahi-net.or.jp/~hc3j-tkg/kterm/"
+LICENSE="X11"
+SLOT="0"
+KEYWORDS="-alpha ~amd64 ~ppc ~sparc ~x86"
+
+RDEPEND="app-text/rman
+ sys-libs/ncurses
+ x11-libs/libXmu
+ x11-libs/libXpm
+ x11-libs/libxkbfile
+ x11-libs/libXaw
+ x11-libs/libXp
+ Xaw3d? ( x11-libs/Xaw3d )"
+
+DEPEND="${RDEPEND}
+ x11-misc/gccmakedep
+ x11-misc/imake"
+
+src_unpack(){
+ unpack ${A}
+
+ cd "${S}"
+ epatch "${WORKDIR}"/${P}-wpi.patch # wallpaper patch
+ epatch "${WORKDIR}"/${P}.ext02.patch # JIS 0213 support
+ epatch "${FILESDIR}"/${P}-openpty.patch
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ epatch "${FILESDIR}"/${PN}-ad-gentoo.diff
+ epatch "${FILESDIR}"/${PV}-underline.patch
+
+ if use Xaw3d ; then
+ epatch "${FILESDIR}"/kterm-6.2.0-Xaw3d.patch
+ fi
+}
+
+src_compile(){
+ xmkmf -a || die
+ emake CC="$(tc-getCC)" CDEBUGFLAGS="${CFLAGS}" LOCAL_LDFLAGS="${LDFLAGS}" \
+ XAPPLOADDIR=/etc/X11/app-defaults || die "emake failed"
+}
+
+src_install(){
+ emake DESTDIR="${D}" BINDIR=/usr/bin XAPPLOADDIR=/etc/X11/app-defaults install || die
+
+ # install man pages
+ newman kterm.man kterm.1
+ insinto /usr/share/man/ja/man1
+ iconv -f ISO-2022-JP -t EUC-JP kterm.jman > kterm.ja.1
+ newins kterm.ja.1 kterm.1
+
+ # Remove link to avoid collision
+ rm -f "${D}"/usr/lib/X11/app-defaults
+
+ dodoc README.kt
+}
+
+pkg_postinst() {
+ elog
+ elog "KTerm wallpaper support is enabled."
+ elog "In order to use this feature,"
+ elog "you need specify favourite xpm file with -wp option"
+ elog
+ elog "\t% kterm -wp filename.xpm"
+ elog
+ elog "or set it with X resource"
+ elog
+ elog "\tKTerm*wallPaper: /path/to/filename.xpm"
+ elog
+}