summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2009-09-04 13:59:09 +0000
committerJeroen Roovers <jer@gentoo.org>2009-09-04 13:59:09 +0000
commit9173de23b12f4aec5ef7b70d1df96a44f89cd885 (patch)
tree1473792e7d8d6dd1c1163e2e687358d086e2f80f /x11-terms/xvt/files
parentremoved the patch. (diff)
downloadhistorical-9173de23b12f4aec5ef7b70d1df96a44f89cd885.tar.gz
historical-9173de23b12f4aec5ef7b70d1df96a44f89cd885.tar.bz2
historical-9173de23b12f4aec5ef7b70d1df96a44f89cd885.zip
Turn seds into patches. Respect CFLAGS (bug #241554), CC.
Package-Manager: portage-2.2_rc40/cvs/Linux i686
Diffstat (limited to 'x11-terms/xvt/files')
-rw-r--r--x11-terms/xvt/files/xvt-int-main.patch23
-rw-r--r--x11-terms/xvt/files/xvt-makefile.patch20
2 files changed, 43 insertions, 0 deletions
diff --git a/x11-terms/xvt/files/xvt-int-main.patch b/x11-terms/xvt/files/xvt-int-main.patch
new file mode 100644
index 000000000000..81baa76ce5e0
--- /dev/null
+++ b/x11-terms/xvt/files/xvt-int-main.patch
@@ -0,0 +1,23 @@
+--- xvt-1.0/xvt.c.orig 2009-09-04 15:49:13.000000000 +0200
++++ xvt-1.0/xvt.c 2009-09-04 15:49:13.000000000 +0200
+@@ -41,9 +41,9 @@
+ #endif /* UKC_LOCATIONS */
+
+ #ifdef __STDC__
+-void main(int,char **);
++int main(int,char **);
+ #else
+-void main();
++int main();
+ #endif
+
+ extern int debugging;
+@@ -67,7 +67,7 @@
+ * master end of the pseudo-teletype pair with the command talking to
+ * the slave.
+ */
+-void
++int
+ main(argc,argv)
+ int argc;
+ char **argv;
diff --git a/x11-terms/xvt/files/xvt-makefile.patch b/x11-terms/xvt/files/xvt-makefile.patch
new file mode 100644
index 000000000000..368fdeeb00be
--- /dev/null
+++ b/x11-terms/xvt/files/xvt-makefile.patch
@@ -0,0 +1,20 @@
+--- xvt-1.0/Makefile.orig 2009-09-04 15:45:08.000000000 +0200
++++ xvt-1.0/Makefile 2009-09-04 15:46:00.000000000 +0200
+@@ -27,7 +27,7 @@
+ #ARCH=AIX3
+ #ARCH=ULTRIX
+ #ARCH=HPUX
+-#ARCH=LINUX
++ARCH=LINUX
+ #
+ #
+ # If this line is uncommented then `Make config' will unclude several options
+@@ -107,7 +107,7 @@
+ OBJ=xvt.o xsetup.o command.o screen.o sbar.o ttyinit.o
+ SRC=xvt.c xsetup.c command.c screen.c sbar.c ttyinit.c
+ #
+-CFLAGS=-O $(INCLUDE) $(OPTIONS) $(DEFS) -D$(ARCH)
++CFLAGS+= $(INCLUDE) $(OPTIONS) $(DEFS) -D$(ARCH)
+ #
+ xvt: $(OBJ)
+ $(CC) $(LDFLAGS) -o xvt $(OBJ) $(LIB) -lX11