summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-02-25 23:56:54 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-02-25 23:56:54 +0000
commit47bbfca6e44567d9af085fff450a8f858d494c95 (patch)
tree123f04501d911fc0c3b75c4f8bb2db3ae3a5e853 /x11-themes/gtk-chtheme/files
parentAdd docbook-xml-dtd dependency, bug #258553. (diff)
downloadhistorical-47bbfca6e44567d9af085fff450a8f858d494c95.tar.gz
historical-47bbfca6e44567d9af085fff450a8f858d494c95.tar.bz2
historical-47bbfca6e44567d9af085fff450a8f858d494c95.zip
Bump to 0.3.1-r2. Fix forced as-needed, bug #248655. Make it work with qgtkstyle, bug #250504.
Package-Manager: portage-2.2_rc23/cvs/Linux x86_64
Diffstat (limited to 'x11-themes/gtk-chtheme/files')
-rw-r--r--x11-themes/gtk-chtheme/files/gtk-chtheme-0.3.1-asneeded.patch24
-rw-r--r--x11-themes/gtk-chtheme/files/gtk-chtheme-0.3.1-qgtkstyle.patch12
2 files changed, 36 insertions, 0 deletions
diff --git a/x11-themes/gtk-chtheme/files/gtk-chtheme-0.3.1-asneeded.patch b/x11-themes/gtk-chtheme/files/gtk-chtheme-0.3.1-asneeded.patch
new file mode 100644
index 000000000000..8cceb98a7565
--- /dev/null
+++ b/x11-themes/gtk-chtheme/files/gtk-chtheme-0.3.1-asneeded.patch
@@ -0,0 +1,24 @@
+# LDFLAGS is for linker flags, not libraries
+# Fixes issue with forced --as-needed
+#
+# https://bugs.gentoo.org/show_bug.cgi?id=248655
+--- a/Makefile 2009-02-26 00:43:54.000000000 +0100
++++ b/Makefile 2009-02-26 00:43:32.000000000 +0100
+@@ -2,7 +2,7 @@
+
+ CFLAGS := $(if $(RPM_OPT_FLAGS), $(RPM_OPT_FLAGS), $(CFLAGS))
+
+-LDFLAGS = $(shell pkg-config --libs gtk+-2.0)
++LIBS = $(shell pkg-config --libs gtk+-2.0)
+ CFLAGS += -Wall
+ CFLAGS += $(shell pkg-config --cflags gtk+-2.0) -DGTK_DISABLE_BROKEN
+ CFLAGS += -DPROJNAME='"$(PROJNAME)"' -DVERSION='"$(VERSION)"'
+@@ -17,7 +17,7 @@
+ all: $(EXENAME) $(EXENAME).1
+
+ $(EXENAME): $(addsuffix .o, $(SRC))
+- $(CC) $(LDFLAGS) $^ -o $@
++ $(CC) $(LDFLAGS) $^ $(LIBS) -o $@
+
+ $(EXENAME).1: $(EXENAME).pod
+ pod2man $< | sed 's/^\.TH .*/.TH $(EXENAME) 1/' > $@
diff --git a/x11-themes/gtk-chtheme/files/gtk-chtheme-0.3.1-qgtkstyle.patch b/x11-themes/gtk-chtheme/files/gtk-chtheme-0.3.1-qgtkstyle.patch
new file mode 100644
index 000000000000..b6c2b7a03551
--- /dev/null
+++ b/x11-themes/gtk-chtheme/files/gtk-chtheme-0.3.1-qgtkstyle.patch
@@ -0,0 +1,12 @@
+# Make gtk-chtheme work with qgtkstyle
+# https://bugs.gentoo.org/show_bug.cgi?id=250504
+--- a/main.c 2004-02-09 06:33:28.000000000 +0200
++++ b/main.c 2008-12-10 12:47:42.000000000 +0200
+@@ -97,6 +97,7 @@
+ fprintf(gtkrc_fh, "gtk-font-name=\"%s\"\n\n", font);
+ }
+
++ fprintf(gtkrc_fh, "gtk-theme-name = \"%s\"\n\n", themename);
+ fprintf(gtkrc_fh, "include \"%s/.gtkrc.mine\"\n\n", getenv("HOME"));
+ fprintf(gtkrc_fh, "# -- THEME AUTO-WRITTEN DO NOT EDIT\n");
+ fclose(gtkrc_fh);