summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2010-06-02 18:00:43 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2010-06-02 18:00:43 +0000
commitccc81c6b57dccda4a0adecd9e76242b9f9c7b63b (patch)
tree13b288e482c4714efca70621ce5fc1cd90ba2f48 /x11-wm/blackbox/blackbox-0.70.1.ebuild
parentAdd to ruby herd. (diff)
downloadhistorical-ccc81c6b57dccda4a0adecd9e76242b9f9c7b63b.tar.gz
historical-ccc81c6b57dccda4a0adecd9e76242b9f9c7b63b.tar.bz2
historical-ccc81c6b57dccda4a0adecd9e76242b9f9c7b63b.zip
Enabling shared libs, fixing as-needed issues wrt bug 248549. Thanks Diego for the report.
Package-Manager: portage-2.1.8.3/cvs/Linux x86_64
Diffstat (limited to 'x11-wm/blackbox/blackbox-0.70.1.ebuild')
-rw-r--r--x11-wm/blackbox/blackbox-0.70.1.ebuild13
1 files changed, 7 insertions, 6 deletions
diff --git a/x11-wm/blackbox/blackbox-0.70.1.ebuild b/x11-wm/blackbox/blackbox-0.70.1.ebuild
index 0627d1325d1d..0c57af6f393d 100644
--- a/x11-wm/blackbox/blackbox-0.70.1.ebuild
+++ b/x11-wm/blackbox/blackbox-0.70.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/blackbox/blackbox-0.70.1.ebuild,v 1.11 2010/02/22 19:53:22 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/blackbox/blackbox-0.70.1.ebuild,v 1.12 2010/06/02 18:00:42 xarthisius Exp $
-inherit eutils
+inherit autotools eutils
DESCRIPTION="A small, fast, full-featured window manager for X"
HOMEPAGE="http://blackboxwm.sourceforge.net/"
@@ -28,7 +28,9 @@ src_unpack() {
unpack ${A}
cd "${S}"
- epatch "${FILESDIR}/${P}-gcc-4.3.patch"
+ epatch "${FILESDIR}/${P}-gcc-4.3.patch" \
+ "${FILESDIR}/${P}-asneeded.patch"
+ eautoreconf
}
src_compile() {
@@ -36,8 +38,7 @@ src_compile() {
--sysconfdir=/etc/X11/${PN} \
$(use_enable debug) \
$(use_enable nls) \
- $(use_enable truetype xft) \
- || die "econf failed"
+ $(use_enable truetype xft)
emake || die "emake failed"
}
@@ -50,5 +51,5 @@ src_install() {
doins "${FILESDIR}/${PN}.desktop"
emake DESTDIR="${D}" install || die "emake install failed"
- dodoc AUTHORS ChangeLog* COMPLIANCE README* TODO
+ dodoc AUTHORS ChangeLog* COMPLIANCE README* TODO || die
}